1076 -- Encoding

Encoding

Time Limit:1000MS  Memory Limit:65536K
Total Submit:66 Accepted:37

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input

The first line contains an integer N (1 < = N < = 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output

ABC
A2B3C

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1076 {
        class Program {
            static void Main(string[] args) {
                int t = int.Parse(Console.ReadLine());
                while (t-- > 0) {
                    int c = 1;
                    string s = Console.ReadLine();
                    for (int i = 1; i < s.Length; i++) {
                        if (s[i] == s[i - 1]) ++c;
                        else {
                            if (c > 1)
                                Console.Write(c);
                            Console.Write(s[i - 1]);
                            c = 1;
                        }
                    }
                    if (s[s.Length - 1] == s[s.Length - 2])
                        Console.Write("{0}{1}", c, s[s.Length - 2]);
                    else
                        Console.Write(s[s.Length - 1]);
                    Console.WriteLine();
                }
            }
        }
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值