1080 -- 奇数检测

奇数检测

Time Limit:1000MS  Memory Limit:65536K
Total Submit:157 Accepted:48

Description

一个数组存放若干整数,只有一个数出现奇数次,其余数均出现偶数次,找出这个出现奇数次的数?

Input

输入中第一行为一个整数T(1 ≤ T ≤ 10),描述后面一共有T组测试数据。每组测试数据的第一个数为数组的长度n ( n > 0 ),跟着n个数据为数组元数。

Output

输出每组数据中出现奇数次的数。

Sample Input

3
5 5 5 5 5 6
7 1 1 2 4 2 3 3 
1 1

Sample Output

6
4
1

Source

zxw

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1080 {
        class Program {
            static void Main(string[] args) {
                int t = int.Parse(Console.ReadLine());
                while (t-- > 0) {
                    string[] s = Console.ReadLine().Split();
                    int n = int.Parse(s[0]);
                    int[] a = new int[10001];
                    for (int i = 1; i <= n; i++)
                        a[int.Parse(s[i])]++;
                    for (int i = 0; i < 10001; i++)
                        if (a[i] != 0 && a[i] % 2 == 1) {
                            Console.WriteLine(i);
                            break;
                        }
                }
            }
        }
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值