1081 -- 小明A+B(2)

小明A+B(2)

Time Limit:1000MS  Memory Limit:65536K
Total Submit:231 Accepted:141

Description

小明最近多位数加法运算学的很晕倒:(,幸好是做判断题,它只需要判断A+B最后一位数是否是C就可以了,可是他真的懒的厉害,这不让你写一个程序帮助他

Input

两个长度超过100位整数A B 一个个位数C

Output

正确与否,正确是YES 错误则输出NO

Sample Input

999999999999999999999999999999999999999999999999999999999999999999999999
88888888888888888888888888888888888888888888888
7

Sample Output

YES

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1081 {
        class Program {
            static void Main(string[] args) {
                string s = Console.ReadLine();
                string b = Console.ReadLine();
                int x = int.Parse(Console.ReadLine());
                int n = (s[s.Length - 1] - '0') + (b[b.Length - 1] - '0');
                if (n % 10 == x)
                    Console.WriteLine("YES");
                else
                    Console.WriteLine("NO");
                //Console.ReadLine();
            }
        }
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值