HDU 3449 Consumer

Problem Description

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.

Input

The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)

Output

For each test case, output the maximum value FJ can get

Sample Input

3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60

Sample Output

210


依赖背包,直接对每一个box进行01背包处理即可。


#include<stdio.h>

int main(){
	int n, m;
	int box[100], c[100][100], v[100][100],a[1000],b[1000];
	while (scanf("%d%d", &n, &m) != EOF)
	{
		int ff[200000] = { 0 };
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &box[i], &c[i][0]);
			for (int j = 1; j <= c[i][0]; j++) scanf("%d%d", &c[i][j], &v[i][j]);
		}
		for (int i = 1; i <= n; i++)
		{
			int f[2000] = { 0 };
			for (int j = 1; j <= c[i][0]; j++)
				for (int k = 1000; k >= c[i][j]; k--)
					if (f[k - c[i][j]] || k == c[i][j])
						f[k] = f[k] < f[k - c[i][j]] + v[i][j] ? f[k - c[i][j]] + v[i][j] : f[k];
			int p = 0;
			for (int j = 0; j <= 1000; j++)
				if (f[j]){ a[p] = j; b[p] = f[j]; p++; }
			for (int k = m; k >=box[i]; k--)
				for (int j = 0; j < p;j++)
					if (k>=a[j]+box[i])
						ff[k] = ff[k] < ff[k - a[j] - box[i]] + b[j] ? ff[k - a[j] - box[i]] + b[j] : ff[k];
		}
		printf("%d\n", ff[m]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值