HDU-3449-Consumer(有依赖背包)

Consumer




Problem Description
FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.
 

Input
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)
 

Output
For each test case, output the maximum value FJ can get
 

Sample Input
 
 

3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60

Sample Output
 
 
210
 

题目意思:N个箱子,每个箱子需要花费Ai的代价

箱子里面有K个物品,K个物品你可以选择买任意个,但每个物品只能买一个,每个物品有相应的花费和价值

你又M的大洋,最后问最多能得到多少价值物品。

解题思路:先对每组选择里的所有物品进行0-1背包处理,但背包容量为(总容量-盒子容量);然后跟上一组的状态比较来决定这一组选择是选还是不选,取其中的较大值。

#include<bits/stdc++.h>
using namespace std;
int dp[100005];
int tmp[100005];
int main()
{
    int n,w,p,m,c,v;
    while(~scanf("%d%d",&n,&w))
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            memcpy(tmp,dp,sizeof(dp));///继承前面的
            scanf("%d%d",&p,&m);
            for(int j=0;j<m;j++)
            {
                scanf("%d%d",&c,&v);
                for(int k=w-p;k>=c;k--)
                {
                    tmp[k]=max(tmp[k],tmp[k-c]+v);
                }
            }
            for(int k=p;k<=w;k++)
            {
                dp[k]=max(dp[k],tmp[k-p]);
            }
        }
        printf("%d\n",dp[w]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值