POJ 3416 Crossing

Description

Wintokk has collected a huge amount of coins at THU. One day he had all his coins fallen on to the ground. Unfortunately, WangDong came by and decided to rob Wintokk of the coins.

They agreed to distribute the coins according to the following rules:

Consider the ground as a plane. Wintokk draws a horizontal line on the plane and then WangDong draws a vertical one so that the plane is divided into 4 parts, as shown below.

Wintokk will save the coins in I and III while those fit in II and IV will be taken away by the robber WangDong.

For fixed locations of the coins owned by Wintokk, they drew several pairs of lines. For each pair, Wintokk wants to know the difference between the number of the saved coins and that of the lost coins.

It's guaranteed that all the coins will lie on neither of the lines drew by that two guys.

Input

The first line contains an integer T, indicating the number of test cases. Then T blocks of test cases follow. For each case, the first line contains two integers N and M, where N is the number of coins on the ground and M indicates how many times they are going to draw the lines. The 2nd to (N+1)-th lines contain the co-ordinates of the coins and the last M lines consist of the M pairs integers (xy) which means that the two splitting lines intersect at point (xy).

(N,≤ 50000, 0 ≤x,≤ 500000)

Output

For each query, output a non-negative integer, the difference described above. Output a blank line between cases.

Sample Input

2
10 3
29 22
17 14
18 23
3 15
6 28
30 27
4 1
26 7
8 0
11 21
2 25
5 10
19 24
10 5
28 18
2 29
6 5
13 12
20 27
15 26
11 9
23 25
10 0
22 24
16 30
14 3
17 21
8 1
7 4

Sample Output

6
4
4

2
2
4
4

4

树状数组

#include<stack>
#include<cmath>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef int ll;
const ll maxn=500005;
const ll low(ll x) {return x&-x;}
ll T,n,m,f[maxn];
vector<int> p[maxn];
struct point
{
	int x,y,flag,id,ans;
	void read(int u,int v)
	{ 
		scanf("%d%d",&x,&y); x++; y++; 
		flag=u;		ans=0;
		if (u) id=v; else id=0;
	}
	bool operator <(const point &a)const
	{
		if (x==a.x) return y<a.y;
		else return x<a.x;
	}
}a[maxn];

bool cmp(const point&a,const point &b)
{
	return a.id < b.id;
}

void insert(int x)
{
	for (int i=x;i<maxn;i+=low(i)) f[i]++;
}

int get(int x)
{
	int tot=0;
	for (int i=x;i;i-=low(i)) tot+=f[i];
	return tot;
}

int main()
{
	scanf("%d",&T);
	while (T--)
	{
		scanf("%d%d",&n,&m);
		for (int i=1;i<=n;i++) a[i].read(0,0);
		for (int i=n+1;i<=n+m;i++) a[i].read(1,i-n);
		sort(a+1,a+n+m+1);
		memset(f,0,sizeof(f));
		for (int i=1;i<=n+m;i++)
		{
			if (a[i].flag) a[i].ans=get(a[i].y);
			else insert(a[i].y);
		}
		memset(f,0,sizeof(f));
		for (int i=n+m;i;i--)
		{
			if (a[i].flag) a[i].ans+=get(maxn-1)-get(a[i].y);
			else insert(a[i].y);
		}
		sort(a+1,a+n+m+1,cmp);
		for (int i=n+1;i<=n+m;i++)
		{
			printf("%d\n",abs(2*a[i].ans-n));
		}
		if (T) printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值