ZOJ 2418 Matrix

63 篇文章 0 订阅

Given an n*n matrix A, whose entries Ai,j are integer numbers ( 0 <= i < n, 0 <= j < n ). An operation SHIFT at row i ( 0 <= i < n ) will move the integers in the row one position right, and the rightmost integer will wrap around to the leftmost column.

You can do the SHIFT operation at arbitrary row, and as many times as you like. Your task is to minimize


Input

The input consists of several test cases. The first line of each test case contains an integer n. Each of the following n lines contains n integers, indicating the matrix A. The input is terminated by a single line with an integer -1. You may assume that 1 <= n <= 7 and |Ai,j| < 104.


Output

For each test case, print a line containing the minimum value of the maximum of column sums.


Sample Input

2
4 6
3 7
3
1 2 3
4 5 6
7 8 9
-1


Sample Output

11

15

直接爆搜就可以过。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<map>
#include<algorithm>
using namespace std;
typedef long long LL;
#define rep(i,j,k) for (int i=j;i<=k;i++)
#define per(i,j,k) for (int i=j;i>=k;i--)
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
typedef pair<int,int> pii;
const int N = 15;
const int INF=0x7FFFFFFF;
int n,a[N][N],b[N],ans;

int calc()
{
    int res=-INF;
    rep(i,0,n-1)
    {
        int cnt=0;
        rep(j,0,n-1)
        {
            cnt+=a[j][(i+b[j])%n];
        }
        res=max(res,cnt);
    }
    return res;
}

void dfs(int x)
{
    if (x==n)
    {
        ans=min(ans,calc());
        return;
    }
    rep(i,0,n-1)
    {
        b[x]=i;
        dfs(x+1);
    }
}

int main()
{
    while (~inone(n)&&n!=-1)
    {
        rep(i,0,n-1) rep(j,0,n-1) inone(a[i][j]);
        ans=INF; b[0]=0; dfs(1);
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值