poj 2078 Matrix

Description

Given an n*n matrix A, whose entries Ai,j are integer numbers ( 0 <= i < n, 0 <= j < n ). An operation SHIFT at row i ( 0 <= i < n ) will move the integers in the row one position right, and the rightmost integer will wrap around to the leftmost column. 

You can do the SHIFT operation at arbitrary row, and as many times as you like. Your task is to minimize 
max0<=j< n{Cj|Cj=Σ0<=i< nAi,j}

Input

The input consists of several test cases. The first line of each test case contains an integer n. Each of the following n lines contains n integers, indicating the matrix A. The input is terminated by a single line with an integer −1. You may assume that 1 <= n <= 7 and |A i,j| < 10 4.

Output

For each test case, print a line containing the minimum value of the maximum of column sums.

Sample Input

2
4 6
3 7
3
1 2 3
4 5 6
7 8 9
-1

Sample Output

11
15

Source



这个题的意思是,给一个矩阵,每一行可以进行变换,把最后一个数放到最前边,,,然后把每一列的数相加,找出最大的数,问你变换之后使得这个列的最大的数最小。。



#include<stdio.h>
#include<math.h>
#include<string.h>
int n;
int a[10][10]={0};
int maxx=-1000000;
int maxp=1000000;
void change(int hang,int a[10][10])
{
    int c,i;
    c=a[hang][n-1];
    for(i=n-1;i>0;i--)
    {
        a[hang][i]=a[hang][i-1];
    }
    a[hang][0]=c;
}
void sumx(int a[10][10])
{
    int i,j,sum=0;
    for(i=0;i<n;i++) //lie
    {
        sum=0;
        for(j=0;j<n;j++)
        {
           sum=sum+a[j][i];
        }
        if(sum>maxx) maxx=sum;
    }
}
void DFS(int p,int a[10][10])
{
   if(p==n) return;
    maxx=-1000000;
   int i,j;
   sumx(a);
   if(maxx<maxp) maxp=maxx;
   for(i=0;i<n;i++)
   {
       change(p,a);
       DFS(p+1,a);
   }
}
int main()
{
    while(scanf("%d",&n),n!=-1)
    {
        int i,j;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        maxp=1000000;
        DFS(0,a);
        printf("%d\n",maxp);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值