cisco 路由器 ADSL拨号上网配置

网络部署 专栏收录该内容
3 篇文章 0 订阅

原文地址:http://blog.sina.com.cn/s/blog_61c07ac501015ek0.htm

虚拟拨号接口

cisco(config)>interface Dialer1 //定义拨号端口Dialer1
cisco(config)>description adsl-dialer
cisco(config)>ip address negotiated //拨号接口的地址是通过协商获得的
cisco(config)>ip mtu 1492 //网络层IP协议会检查每个从上层协议下来的数据包的大小,并根据本机MTU的大小决定是否作“分片”处理(因为pppoe会增加8个字节头部)
cisco(config)>encapsulation ppp //用于配置广域网协议ISDN,就是一种上互联网的拨号方式
cisco(config)>dialer pool 1 //该端口使用1号拨号池进行拨号
cisco(config)>ppp pap sent-username XXXXXXX password XXXXXX //此处虚拟拨号口使用的是pap认证方式,配置账号、密码
cisco(config)>ppp ipcp dns request //向服务器请求DNS地址
cisco(config)>ip virtual-reassembly max-reassemblies 1024 //防止碎片攻击

物理端口(绑定上述拨号端口)

cisco(config)>interface GigabitEthernet0/1
cisco(config)>description bind-dialer
cisco(config)>no ip address
cisco(config)>ip virtual-reassembly in
cisco(config)>duplex auto
cisco(config)>speed auto
cisco(config)>pppoe enable
cisco(config)>pppoe-client dial-pool-number 1
cisco(config)>no shut

查看拨号是否拨通

cisco#>show interfaces dialer 1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Description: adsl-dialer
  Internet address is 121.112.11.11/24    //拨号获得的IP地址
  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
(省略)

Bound to:
Virtual-Access2 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 36/255, rxload 22/255
  Encapsulation PPP, LCP Open
  Listen: CDPCP
  Open: IPCP
  PPPoE vaccess, cloned from Dialer1
  (省略)
  5 minute input rate 5000 bits/sec, 8 packets/sec
  5 minute output rate 8000 bits/sec, 7 packets/sec
  (省略)

内网配置

cisco(config)>int GigabitEthernet0/0 //用于连接内网
cisco(config-if)>ip address 192.168.1.1 255.255.255.0   //配
置内网接口地址,同时也确定你内网主机的网段和网关地址
cisco(config-if)>no shut
/*NAT转换
分三步,
Step1:建立访问控制列表,用来指定NAT转换的源地址范围;
Step2:NAT转换;
Step3:指定NAT转换的入端口和出端口*/
cisco(config)#access-list 10 permit 192.168.1.0 0.0.0.255
//建立访问控制列表10,指定允许做NAT转换的源地址范围

cisco(config)#ip nat inside source list 10 interface dialer 1 overload
//允许ACL10范围的地址映射到dialer1口的地址,必需加上overload参数,因为是多路复用
cisco(config)#int Gig0/0
cisco(config-if)#ip nat inside    //设置NAT转换源地址入口
cisco(config-if)#exit
cisco(config)#int dialer 1   //进入虚拟口配置
cisco(config-if)#ip nat outside   //设置NAT转换的外网地址的出口
cisco(config-if)#exit

路由设置

cisco(config)#ip route 0.0.0.0 0.0.0.0 Dialer1

DNS代理

cisco(config)#ip dns server   //启用DNS代理服务,前提是你通过拨号获得了DNS地址

DHCP配置

配置了DHCP后,你家庭内网的主机接入就不用手工配置网络了,配置如下

cisco#config t
Enter configuration commands, one per line.  End with CNTL/Z.
cisco(config)#ip dhcp excluded-address 192.168.1.2 192.168.1.5    //在分配中排除地址192.168.1.2~192.168.1.5
cisco(config)#ip dhcp pool Local //建立一个DHCP分配池,命名为“Local”
cisco(dhcp-config)#network 192.168.1.0 255.255.255.0 //分配这个网段的地址,同时也根据路由表向该网段所在的接口分配
cisco(dhcp-config)#default-router 192.168.1.1 //指定网关地址
cisco(dhcp-config)#dns-server 192.168.1.1 //指定DNS服务器地址(可以自己百度搜索些公用的DNS)
cisco(dhcp-config)#exit

端口状态查看命令

确保ip分配,端口启用

cisco#>show ip inter brief
  • 6
    点赞
  • 2
    评论
  • 14
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值