PTA 甲1092&1001 A+B Format

PTA 1092 To Buy or Not to Buy (20 分)

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.
在这里插入图片描述
Input Specification:
Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:
For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY
结尾无空行

Sample Output 1:

Yes 8
结尾无空行

Sample Input 2:

ppRYYGrrYB225
YrR8RrY
结尾无空行

Sample Output 2:

No 2
结尾无空行

思路来源:算法笔记的非数字的哈希
注意:gets()不安全

#include<bits/stdc++.h>
#include<string.h>
using namespace std;
int main(){
	char ch,s1[1000],s2[1000];
	int n1[256]={0},tmp,res=0;
	scanf("%s",s1);scanf("%s",s2);
	for(int i=0;i<strlen(s1);i++){
		if((s1[i]>='a'&&s1[i]<='z')||(s1[i]>='A'&&s1[i]<='Z')) {
			tmp=s1[i]-'A'+10;n1[tmp]++;
		}
		else{
			tmp=s1[i]-'0';n1[tmp]++;
		}
	}
	for(int i=0;i<strlen(s2);i++){
		if((s2[i]>='a'&&s2[i]<='z')||(s2[i]>='A'&&s2[i]<='Z')) {
			tmp=s2[i]-'A'+10;
			n1[tmp]--;
		}
		else{
			tmp=s2[i]-'0';n1[tmp]--;
		}
	}
	/*
	for(int i=0;i<256;i++){
		res+=n1[i];
	}
	if(res>=0){
		printf("Yes %d",strlen(s1)-strlen(s2));
	}
	else
		printf("No %d",-res);*/
	//应该是有一个是负数就不行
	int flag=0;
	for(int i=0;i<256;i++){
		if(n1[i]<0){
			res-=n1[i];flag=1;
		}
	} 
	if(!flag){
		printf("Yes %d",strlen(s1)-strlen(s2));
	}
	else
		printf("No %d",res);
	return 0;
} 

什么时候才能300-500道题!!!没事就刷鸭,没竞赛就疯狂刷

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10^6
≤a,b≤10^6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991
真就这样,找数字的规律嘛?? 感觉不对劲就换思路啊!
不会怎么数字转字符串
c++: string s = to_string(a + b);

#include<bits/stdc++.h>
using namespace std;
int main(){
    int a,b,sum,t,flag;
    scanf("%d%d", &a,&b);        
    sum=a+b;t=sum;
    if(sum<0){
        printf("-");sum=-sum;t=sum;
    }
    if(t>=1000000) flag=4;
    else if(t>100000) flag=3;
    else if(t>10000) flag=2;
    else if(t>1000) flag=1;
    else flag=0;
    if(flag!=0){
        printf("%d",sum/1000);
        printf(",");
        /*printf("%d",(sum-(sum/1000)*1000));
        if(sum%1000==0) {printf("%d",(sum-(sum/1000)*1000));printf("%d",(sum-(sum/1000)*1000));}*/
         if(flag==4) {printf("%d",(sum/100)%10);
        printf("%d",(sum/10)%100);
        printf("%d",sum%1000);}
        if(flag==1) {printf("%d",(sum/100)%10);
        printf("%d",(sum/10)%100);
        printf("%d",sum%1000);}
        
    }
   else{
        printf("%d",sum);        
    }
               return 0;
}

正解: 倒叙插入,输出字符串

#include <iostream>
using namespace std;
int main() {
    int a, b;
    cin >> a >> b; //输入a和b
    string s = to_string(a + b); //将a+b的值转换为字符串
    if(s[0] == '-') { //处理符号
        cout << '-';
        s.erase(0, 1);//删除第一个字符
    }
    int count = 0; //用于记录当前位置
    for(int i = s.length() - 1; i >= 0; i--){ //添加逗号
        count++;
        if(count % 3 == 0 && i > 0){
            s.insert(i, ",");
        }
    }
    cout << s;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值