PTA甲级-1001 A+B Format c++

题目内容

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

一、题干大意

这道题的意思就是说给定两个数把它们加起来,然后按从后往前每隔三位一个逗号的格式输出。

二、题解要点

  • 总体思路就是把相加的结果拆成一位一位装入向量中,然后把向量输出。在输出的同时控制逗号的输出。
  • 全零输入也要有0的输出,测试点4就是针对这个的检查

三、具体实现

#include<iostream>
#include<vector>
using namespace std;

int main(){
	int a,b,myResult,length;
	vector<int> myOut(0);
	
	cin>>a>>b;
	myResult = a + b;
	/*如果和是负数 就直接改成正数并输出负号*/
	if(myResult<0){
		myResult = - myResult;
		cout<<"-";
	}
	/*测试点4 是0 0的输入 所以要输出0*/
	if(myResult == 0){
		cout<<0;
		return 0;
	}
	/*将数字一个个装入向量中*/
	while(myResult!=0){
		int temp = myResult % 10;
		myResult /= 10;
		myOut.push_back(temp);
		
	}
	
	length = myOut.size();
	for(int i=0;i<length;i++){
		cout<<myOut[length-i-1];
		/*这么写是为了防止最后数字输出结束了还会再输出一个逗号*/
		if((length	- i -1)%3 == 0 && (length	- i -1)!= 0){ 
			cout<<",";
		}
	}
	
	return 0;
}

总结

总体来说难度不大,就是要防范数字输出完了结果逗号还在输出(就是数字位数为3的倍数的情况)。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值