Eqs
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 16239 | Accepted: 7973 |
Description
Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.
Determine how many solutions satisfy the given equation.
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.
Determine how many solutions satisfy the given equation.
Input
The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output
The output will contain on the first line the number of the solutions for the given equation.
Sample Input
37 29 41 43 47
Sample Output
654
Source
题意:一个五元三次方程,给定五个系数,范围[-50,50],求在{x | -50<=x<=50, x != 0},范围内有多少组解。思路:分成两部分,先暴力算出的a1x13+ a2x23所有解,显然最大值可能为50*50*50*50*2=12,500,000,由于可能出现负值,将负值向右偏移12,500,000 * 2 + 1,+1是为了防止-12,500,000偏移后和12,500,000撞车,hash数组用short类型就不会超内存。
# include <iostream>
# include <cstdio>
# include <cstring>
# define maxn 25000000
using namespace std;
short Hash[maxn+3];
int main()
{
int a, b, c, d, e, ans;
while(~scanf("%d%d%d%d%d",&a,&b,&c,&d,&e))
{
ans = 0;
memset(Hash, 0, sizeof(Hash));
for(int i=-50; i<=50; ++i)
{
if(i==0) continue;
for(int j=-50; j<=50; ++j)
{
if(j==0) continue;
int tmp = (i*i*i*a+j*j*j*b)*-1;
if(tmp < 0)
tmp += 25000000+1;
++Hash[tmp];
}
}
for(int i=-50; i<=50; ++i)
{
if(i==0) continue;
for(int j=-50; j<=50; ++j)
{
if(j==0) continue;
for(int k=-50; k<=50; ++k)
{
if(k==0) continue;
int tmp = c*i*i*i+d*j*j*j+e*k*k*k;
if(tmp < 0)
tmp += 25000000+1;
ans += Hash[tmp];
}
}
}
printf("%d\n",ans);
}
return 0;
}