D - Eqs解题报告

Description

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
#include<iostream>
using namespace std;
short hash[25000001];  //hash[sum]表示值等于sum的的解的个数(多对1映射)
int main(void)
{
      int a1,a2,a3,a4,a5;  //系数
      while(cin>>a1>>a2>>a3>>a4>>a5)
      {
           memset(hash,0,sizeof(hash));
           for(int x1=-50;x1<=50;x1++)
           {
                 if(!x1)            //x不为0;
                      continue;
                 for(int x2=-50;x2<=50;x2++)
                 {
                      if(!x2)      //x不为0;
                            continue;
                      int sum=(a1*x1*x1*x1+a2*x2*x2*x2)*(-1);  //计算前两项的和,-
                      if(sum<0)   //50*50^3+50*50^3=12500000,由于sum也可能为负数,
                            sum+=25000000;//当sum<0时,我们令sum+=25000000存储到hash[]
                      hash[sum]++;
                 }
           }
           int solution=0;
           for(int x3=-50;x3<=50;x3++)
           {
                 if(!x3)          //x不为0;
                     continue;
                 for(int x4=-50;x4<=50;x4++)
                 {
                      if(!x4)        //x不为0;
                            continue;
                      for(int x5=-50;x5<=50;x5++)
                      {
                            if(!x5)   //x不为0;
                                  continue;
                            int sum=a3*x3*x3*x3 + a4*x4*x4*x4 + a5*x5*x5*x5;  //计算后三项的和();
                           if(sum<0)
                                 sum+=25000000;
                            if(hash[sum])
                                  solution+=hash[sum];//对于方程左边,当x1=m  ,  
                                          //之所以是记录“次数”,而不是记录“是否已出现”,
                      }
                 }
           }
           cout<<solution<<endl;
      }                     
      return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值