AtCoder:Nuske vs Phantom Thnook(思维 & 树)

C - Nuske vs Phantom Thnook


Time limit : 4sec / Memory limit : 256MB

Score : 700 points

Problem Statement

Nuske has a grid with N rows and M columns of squares. The rows are numbered 1 through N from top to bottom, and the columns are numbered 1 through M from left to right. Each square in the grid is painted in either blue or white. If Si,j is 1, the square at the i-th row and j-th column is blue; if Si,j is 0, the square is white. For every pair of two blue square a and b, there is at most one path that starts from a, repeatedly proceeds to an adjacent (side by side) blue square and finally reaches b, without traversing the same square more than once.

Phantom Thnook, Nuske's eternal rival, gives Q queries to Nuske. The i-th query consists of four integers xi,1yi,1xi,2 and yi,2 and asks him the following: when the rectangular region of the grid bounded by (and including) the xi,1-th row, xi,2-th row, yi,1-th column and yi,2-th column is cut out, how many connected components consisting of blue squares there are in the region?

Process all the queries.

Constraints

  • 1N,M2000
  • 1Q200000
  • Si,j is either 0 or 1.
  • Si,j satisfies the condition explained in the statement.
  • 1xi,1xi,2N(1iQ)
  • 1yi,1yi,2M(1iQ)

Input

The input is given from Standard Input in the following format:

N M Q
S1,1..S1,M
:
SN,1..SN,M
x1,1 yi,1 xi,2 yi,2
:
xQ,1 yQ,1 xQ,2 yQ,2

Output

For each query, print the number of the connected components consisting of blue squares in the region.


Sample Input 1

Copy
3 4 4
1101
0110
1101
1 1 3 4
1 1 3 1
2 2 3 4
1 2 2 4

Sample Output 1

Copy
3
2
2
2

In the first query, the whole grid is specified. There are three components consisting of blue squares, and thus 3 should be printed.

In the second query, the region within the red frame is specified. There are two components consisting of blue squares, and thus 2 should be printed. Note that squares that belong to the same component in the original grid may belong to different components.


Sample Input 2

Copy
5 5 6
11010
01110
10101
11101
01010
1 1 5 5
1 2 4 5
2 3 3 4
3 3 3 3
3 1 3 5
1 1 3 4

Sample Output 2

Copy
3
2
1
1
3
2
题意:给一个n*m的格,蓝色的组成路径保证不成环,q个询问,计算指定矩形区域内大联通快的个数。

思路:显然每个小矩形的蓝色路径也不会成环,那么按照树的定义,算到区域内相邻蓝色的数目,即边数,用蓝色格子总数减去它就是森林数了,那么需要预处理下这些东西。

# include <bits/stdc++.h>
using namespace std;


typedef long long LL;
const int N = 2003;
char s[N][N];
int l[N][N]={0}, r[N][N]={0}, o[N][N]={0};
int main()
{
    int n, m, q, a, b, c, d, A, B, C, D;
    scanf("%d%d%d",&n,&m,&q);
    for(int i=1; i<=n; ++i)
        scanf("%s",s[i]+1);
    for(int i=1; i<=n; ++i)
    {
        for(int j=1; j<=m; ++j)
        {
            l[i][j] = l[i][j-1] + l[i-1][j] - l[i-1][j-1];//保存(1,1)到(i,j)有多少个横连通。
            o[i][j] = o[i][j-1] + o[i-1][j] - o[i-1][j-1];//保存(1,1)到(i,j)有多少个蓝色块。
            r[j][i] = r[j][i-1] + r[j-1][i] - r[j-1][i-1];//保存(1,1)到(i,j)有多少个列连通。(j列i行)。
            if(s[i][j]=='1')
            {
                ++o[i][j];
                if(s[i][j-1] == '1') ++l[i][j];
                if(s[i-1][j] == '1') ++r[j][i];
            }
        }
    }
    while(q--)
    {
        scanf("%d%d%d%d",&A,&B,&C,&D);
        a = min(A, C);
        b = min(B, D);
        c = max(A, C);
        d = max(B, D);
        int cnt, line;
        cnt = o[c][d] - o[c][b-1] - o[a-1][d] + o[a-1][b-1];//加上多减的公共部分。
        line = l[c][d] - l[c][b] - l[a-1][d] + l[a-1][b];
        line += r[d][c] - r[b-1][c] - r[d][a] + r[b-1][a];
        printf("%d\n",cnt-line);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值