POJ3318:Matrix Multiplication(矩阵相乘)

Matrix Multiplication
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19099 Accepted: 4108

Description

You are given three n × n matrices AB and C. Does the equation A × B = C hold true?

Input

The first line of input contains a positive integer n (n ≤ 500) followed by the the three matrices AB and respectively. Each matrix's description is a block of n × n integers.

It guarantees that the elements of A and B are less than 100 in absolute value and elements of C are less than 10,000,000 in absolute value.

Output

Output "YES" if the equation holds true, otherwise "NO".

Sample Input

2
1 0
2 3
5 1
0 8
5 1
10 26

Sample Output

YES

Hint

Multiple inputs will be tested. So O(n 3) algorithm will get TLE.

Source


题意:给三个N阶矩阵ABC,问是否满足A x B = C。

思路:O(n^3)输入不加优化会超时,可以等号两边右乘一个N*1的矩阵,就达到降维的效果了,但这个N*1矩阵取值不合适可能WA。

# include <iostream>
# include <cstdio>
# include <cmath>
# include <cstring>
using namespace std;
typedef long long LL;
LL a[503][503], b[503][503], c[503][503];
LL t[503], s[503], seed[503];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int flag = 1;
        memset(t, 0, sizeof(t));
        memset(s, 0, sizeof(s));
        for(int i=0; i<n; ++i)
            seed[i] = i+1;
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
            scanf("%lld",&a[i][j]);
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
            scanf("%lld",&b[i][j]);
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
            scanf("%lld",&c[i][j]);
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
                t[i] += b[i][j]*seed[j];
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
                s[i] += a[i][j]*t[j];
        for(int i=0; i<n; ++i)
        {
            LL sum = 0;
            for(int j=0; j<n; ++j)
                sum += c[i][j]*seed[j];
            if(sum != s[i])
            {
                flag = 0;
                break;
            }
        }
        if(!flag) puts("NO");
        else puts("YES");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值