3712. Matrix multiplication

3712. Matrix multiplication
 
 
Total: 565 Accepted: 127 Rating:
2.0/5.0(1 votes)
 
     
     
 
Time Limit: 1sec    Memory Limit:256MB
Description
Given two n*n matrices, A and B, computes its matrices multiplication C=A∙B.
Input
There are multiples test cases. Each case is:
The first line is an integer n(<=10), meaning the size of the matrix. For the following 2*n lines, each line contains n integers. The first n lines contain the elements in matrix A.
Input is terminated by EOF.
Output
For each test case, output:
The multiplication C= A∙B, there will be n lines and each line contains n integers, separating the integers by a space.
Sample Input
 Copy sample input to clipboard
2
1 2
3 4
1 1
1 1
Sample Output
3 3
7 7

// source code of submission 962891, Zhongshan University Online Judge System
#include <iostream>
using namespace std;

int main ()
{
    int n;
    while (cin >> n)
    {
        int a1[100][100],a2[100][100],a3[100][100];
        for (int i = 0 ; i < n ; i++)
        {
            for (int j = 0 ; j < n ; j++)
            {
                cin >> a1[i][j];
            }
        }
        for (int i = 0 ; i < n ; i++)
        {
            for (int j = 0 ; j < n ; j++)
            {
                cin >> a2[i][j];
            }
        }
        for (int i = 0 ; i < n ; i++)
        {
            for (int j = 0 ; j < n ; j++)
            {
                a3[i][j] = 0;
            }
        }
        for (int i = 0; i < n ; i++)
        {
            for (int j = 0 ; j < n ; j++)
            {
                for (int k = 0; k < n ; k++)
                {
                    a3[i][j] += (a1[i][k] * a2[k][j]);
                }
            }        
         }
         for (int i = 0 ; i < n ; i++)
        {
            for (int j = 0 ; j < n ; j++)
            {
                if (j != n - 1)
                    cout << a3[i][j] << " ";
                else 
                    cout << a3[i][j];
            }
            cout << endl;
        }
    }
    return 0;                
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值