Radar Installation(贪心)

C - Radar Installation
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each 
small island is a point locating in the sea side. And any radar installation, locating on the coasting, can 
only cover d distance, so an island in the sea can be covered by a radius installation, if the distance 
between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, 
and the land side below. Given the position of each island in the sea, and given the distance of the 
coverage of the radar installation, your task is to write a program to find the minimal number of radar 
i nstallations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, 
where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed 
b y n lines each containing two integers representing the coordinate of the position of each island. Then a blank line 
follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar 
installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

译:

[Description]
在茫茫大海中分布了若干岛屿,现在需要在海岸线上安装雷达来监控这些岛屿,现在知道
岛屿的位置,用 X-Y 坐标系表示,和雷达的监控半径 d,请问最少安装多少个雷达能够监
控所有的岛屿。如图:

[Input]
输入包含多组测试数据。每组测试数据的第一行包含两个整数 n,d,表示岛屿数量和雷达
监控半径。接下来 n 行,每行两个整数,xi,yi,表示第 i 个岛屿的位置。每组测试数据之间
有一个空行。当 n=d=0 时结束输入。
[Output]
对于每组测试数据,输出需要安装的最少雷达数,注意格式:Case i: x,i 表示第几组测试
数据,x 表示答案。不能完成时,x=-1。
[Sample Input]
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
[Sample Output]
Case 1: 2
Case 2: 1
[Hint]
0<n<=1,000


第一眼看就是一道贪心

我们找一个岛屿能被侦测到的极限范围,在雷达侦测区(圆)的左半圆上或者在雷达侦测区(圆)的右半圆上,换句话说当岛屿到雷达的距离等于d时,

    雷达可以位于岛屿的左侧也可以位于雷达的右侧。而这就可以分别确定雷达相对与岛屿x的最左坐标和x最右坐标。

    最左为:x - sqrt(d*d-y*y); 最右为:x - sqrt(d*d-y*y); 

    每个岛屿都有这样的最左和最右可被侦测坐标。

    根据贪心的思想,每次都应该将最右可被侦测坐标作为衡量标准。

    假定当前的岛屿为cur,当前的下一个为next

      1.如果next的最左可被侦测坐标比cur的最右都大的话,只能再设一个雷达来侦测next了。

      2.如果next的最左可被侦测坐标比cur的最右小,这时会有两种情况。

          A.next最右 < cur最右

          B.next最右 >= cur最右

        对于B情况,我们可以直接侦测到next可以找nextnext.

        对于A情况,也就等价于next包含于cur, 这样就应该把next的右最为衡量标准了.

        因为这样可以左移最右坐标可以让可能更多的岛屿被侦测到(他们的最左与衡量标准有更多的交集)


但是这道题注意浮点误差!以及sqrt(double)的使用

#include<cmath>
#include<cstdio>
#include<algorithm>
#include<iostream>
#define MAXN 1010
using namespace std;
struct node 
{
	double xl;//最左可被侦测坐标
	double xr;//最右可被侦测坐标
}island[MAXN];
int n,d,x,y,cnt,flag;
double offset;

bool cmp(node a,node b)
{
	return a.xl<b.xl;
}

int find()
{
	int num=0;
	double cur; 	//当前最右可被侦测坐标 
	cur=island[1].xr;
	num++;
	for(int i=2;i<=n;i++)
	{
		if(island[i].xl-cur>1e-6) //下个岛屿的最左坐标大于当前最右可被侦测坐标 
		{
			num++;
			cur=island[i].xr;
		}
		else
			if(island[i].xr-cur<1e-6) //下个岛屿的最右坐标小于当前最右可被侦测坐标 
			    cur=island[i].xr;
	}
	return num; 
}

int main()
{
    while(scanf("%d %d",&n,&d)==2)
    {
    	if(n==0&&d==0)break;
        flag=0;
        cnt++;
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d",&x,&y);
            if(y>d)	flag=1;
            
            offset=sqrt((double)(d*d-y*y));
            
            island[i].xl=x-offset;
            island[i].xr=x+offset;
        }
        if(flag)
        {
            printf("Case %d: -1\n",cnt);
            continue;
        }
        sort(island+1,island+n+1,cmp);
        int ans=find();
        printf("Case %d: %d\n",cnt,ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值