Coins (HDU 2844) —— 多重背包

写这题花了我一天时间,而且还没写出来,故借鉴了别人的文章:http://blog.csdn.net/lyhvoyage/article/details/8777540

基本上就是多重背包的模板了。。

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6807    Accepted Submission(s): 2771


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.


 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.


 

Output
For each test case output the answer on a single line.


 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0


 

Sample Output
  
  
8 4

自己跟着也写了。。

#include<stdio.h>
int a[110],c[110],dp[100010];

int maxn(int i,int j) {return i > j ? i : j;}
void CompletePack(int v,int w,int m)
{
    for(int j=v; j<=m; j++)
        dp[j] = maxn(dp[j],dp[j-v]+w);
}
void ZeroOnePack(int v,int w,int m)
{
    for(int j=m; j>=v; j--)
        dp[j] = maxn(dp[j],dp[j-v]+w);
}
void MultiPack(int v,int w,int m,int c)
{
    if(v*c > m) CompletePack(v,w,m);
    else
    {
        int k = 1;
        while(k < c)
        {
            ZeroOnePack(k*v,k*w,m);
            c -= k;
            k *= 2;
        }
        ZeroOnePack(c*v,c*w,m);
    }
}
int main()
{
    int i,j,n,m;

    while(~scanf("%d%d", &n,&m),n+m)
    {
        for(i=1; i<=m; i++) dp[i] = 0;
        for(i=1; i<=n; i++)
            scanf("%d", a+i);
        for(i=1; i<=n; i++)
            scanf("%d", c+i);
        for(i=1; i<=n; i++)
            MultiPack(a[i],a[i],m,c[i]);
        int sum = 0;
        for(i=1; i<=m; i++)
            if(dp[i] == i) sum++;
        printf("%d\n", sum);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值