HDU 2844:Coins

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16707    Accepted Submission(s): 6636


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4
 

Source


题意:
给定n种物品和一个m的总价格,又给出物品的面值和数量,求可以组成多少个不超过m的数。
解题思路:
首先我们可以判断他是一个多重背包问题。在金额的限制条件下求的最大的价值,如果说在多重背包求得的dp[i]=i.可以认为可以恰好组成这个不差过m的价值。
动态转移方程:dp[i]=max(dp[i],dp[i-w]+w);//i不差过m的金额,w表示面值,dp该金额下的最大价值。



源代码:


#include<cstdio>
#include<cstring>
const int N=105;
//const int NINF=-0x3f3f3f3f;
int max(int a, int b){return a>b?a:b;}
int V,m;
int dp[100005];
int w[N],num[N];
void MultiplePack(int n,int w)
{
    if(n*w>=V)//完全背包
    {
        for(int i=w;i<=V;i++)
            dp[i]=max(dp[i],dp[i-w]+w);
        return ;
    }
    int k=1;
    int nC=n;
    while(k<nC)//01背包,做简单的优化
    {
        for(int i=V;i>=k*w;i--)
            dp[i]=max(dp[i],dp[i-k*w]+k*w);
        nC-=k;
        k*=2;
    }
    for(int i=V;i>=nC*w;i--)
        dp[i]=max(dp[i],dp[i-nC*w]+nC*w);
}
int main()
{
    while(scanf("%d%d",&m,&V),m!=0&&V!=0)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<m;i++)
            scanf("%d",&w[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&num[i]);
        for(int i=0;i<m;i++)//多重背包
        {
            MultiplePack(num[i],w[i]);
        }
        int cont=0;
        for(int i=1;i<=V;i++)//判断符合的个数,即最后答案
        {
            if(dp[i]==i) cont++;
        }
        printf("%d\n",cont);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值