Coins HDU - 2844(多重背包)

Coins HDU - 2844 (多重背包)
Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
有数量限制,就再用一个数组,来控制数量,让求1到m,就看看dp是否能够被赋予其他值,如果可以就,说明可以达到这个数字,标记,用dp=0或1来标记

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f
int v[100005];
int w[100005];
int  dp[100005];
int num[100005];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF&&n&&m)
    {
        memset(dp,0,sizeof(dp));
        int i,j;
        for(i=0; i<n; i++)
            scanf("%d",&v[i]);
        for(i=0; i<n; i++)
            scanf("%d",&w[i]);
        dp[0]=1;    //这个0,不要钱的时候肯定能达到
        int s=0;
        for(i=0; i<n; i++)
        {
            memset(num,0,sizeof(num));  //每一次都要给这个控制数量的更新
            for(j=v[i]; j<=m; j++)
            {
                if(dp[j-v[i]]&&!dp[j]&&num[j-v[i]]<w[i])
                {          //如果dp[j-v[i]]!=0,说明这个点可以被之前的钱表示
                    s++;   //如果dp[j]不存在,说明可以用之前的再加上V[i]来表
                    dp[j]=1; //示这个点,然后num[j-v[i]]要比w[i]这个数量少
                    num[j]=num[j-v[i]]+1; //这样后面才能进入if,再使用一下
                }          //这个数的钱,,,,然后s++,标记dp,给num[j]赋值
            }               //为上一个的值再加一
        }
        printf("%d\n",s);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值