poj 3984 迷宫问题 bfs

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
   

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


打印路径的bfs,我用的栈,也可以用C++自带的递归函数


#include<iostream>
#include<queue>
#include<stack>
#include<cstring>
#include<cstdio>
using namespace std;

int wl[4][2]= {-1,0,0,1,1,0,0,-1};
int flag[5][5];
int a[5][5];

struct node
{
    int x,y;
    node(int x=0,int y=0):x(x),y(y) {}
};
node we[6][6];
int nx,ny;
void bfs()
{
    int x,i,j,y;
    memset(flag,0,sizeof(flag));
    queue<node> que;
    que.push(node(0,0));
    flag[0][0]=1;
    while(!que.empty())
    {
        node t=que.front();
        x=t.x;
        y=t.y;
        que.pop();

        if(x==4&&y==4)
        {
            break;
        }
        for(i=0; i<4; i++)
        {
            nx=x+wl[i][0];
            ny=y+wl[i][1];
            if(nx>=0&&ny>=0&&nx<5&&ny<5&&flag[nx][ny]==0&&a[nx][ny]==0)
            {
                flag[nx][ny]=1;
                we[nx][ny].x=x;
                we[nx][ny].y=y;
                que.push(node(nx,ny));
            }
        }
    }
}

void print()
{
    stack<node> stk;
    int x=4,y=4,tx,ty;
    stk.push(node(4,4));
    while(x!=0||y!=0)
    {
        tx=x;
        ty=y;
        x=we[tx][ty].x;
        y=we[tx][ty].y;
        stk.push(node(x,y));
    }

    while(!stk.empty())
    {
        node t=stk.top();
        stk.pop();
        printf("(%d, %d)\n",t.x,t.y);
    }
}

int main()
{
    int i,j;
    for(i=0; i<5; i++)
        for(j=0; j<5; j++)
            scanf("%d",&a[i][j]);
    bfs();
    print();
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值