hdu 3519 Lucky Coins Sequence 矩阵快速幂

Lucky Coins Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 921    Accepted Submission(s): 488

Problem Description

As we all know,every coin has two sides,with one side facing up and another side facing down.Now,We consider two coins's state is same if they both facing up or down.If we have N coins and put them in a line,all of us know that it will be 2^N different ways.We call a "N coins sequence" as a Lucky Coins Sequence only if there exists more than two continuous coins's state are same.How many different Lucky Coins Sequences exist?

 

Input

There will be sevaral test cases.For each test case,the first line is only a positive integer n,which means n coins put in a line.Also,n not exceed 10^9.

 

Output

You should output the ways of lucky coins sequences exist with n coins ,but the answer will be very large,so you just output the answer module 10007.

 

 

Sample Input

3

4


Sample Output

2

6


硬币所有可能排列情况为2^n,朝向相同硬币连续三个以下 的排列情况为a(1)=2,a(2)=4,a(3)=6,a(4)=10,观察或者推算得a(n)=a(n-1)+a(n-2);

那么连续三个或三个以上硬币的所有组合情况 为b(n)=2^n-a(n);

化为只含b(n)的递推式即 b(n)=b(n-1)+b(n-2)+2^(n-2);b(1)=0;b(2)=0;b(3)=2;b(4)=6;用矩阵快速幂可快速算得b(n);

在这里讲一下矩阵快速幂求递推式的原理:


b(n)            1 1 1              b(n-1)

b(n-1)    =( 1 0 0 )  *  (    b(n-2)    )

2^(n-1)       0 0 2             2^(n-2)


显然你要求b(n)需调用n次上式,即

b(n)             1 1 1                 b(2)

b(n-1)     =( 1 0 0  )^n    *(  b(1)  )

2^(n-1)        0 0 2                  2


                                        1 1 1

我们有矩阵快速幂,计算 ( 1 0 0 )^n时间复杂度只用log n,和快速幂的时间复杂度一样,所以此法可行.

                                         0 0 2 


                       1 1 1

那么b(n)就是 ( 1 0 0 )^n 的第一行第三列与2的乘积(因为b(1)和b(2)都是0);

                       0 0 2


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

const int mod=10007;
struct node
{
    int a[4][4];
    node()
    {
        a[1][1]=a[1][2]=a[1][3]=a[2][1]=1;
        a[2][2]=a[2][3]=a[3][1]=a[3][2]=0;
        a[3][3]=2;
    }
    void init()           //将其初始化为单位矩阵
    {
        memset(a,0,sizeof(a));
        for(int i=1; i<4; i++)
            a[i][i]=1;
    }
};

node mul(node a,node b)  //(a*b)%mod  矩阵乘法
{
    node ans;
    for(int i=1; i<4; i++)
        for(int j=1; j<4; j++)
        {
            ans.a[i][j]=0;
            for(int k=1; k<4; k++)
                ans.a[i][j]+=a.a[i][k]*b.a[k][j];
            ans.a[i][j]%=mod;
        }
    return ans;
}
node power(node a,int n)    //(a^n)%mod  //矩阵快速幂
{
    node ans;
    ans.init();
    while(n)
    {
        if(n%2)//n&1
            ans=mul(ans,a);
        n/=2;
        a=mul(a,a);
    }
    return ans;
}
int main()
{
    int i,j,n;
    while(~scanf("%d",&n))
    {
        if(n<3){printf("0\n");continue;}
        node ans;
        ans=power(ans,n-2);
        /*     for(i=1;i<4;i++)
             {for(j=1;j<4;j++)
              printf("%d",ans.a[i][j]);
             printf("\n");}*/
        printf("%d\n",(ans.a[1][3]*2)%mod);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值