ZOJ 1586 QS Network(kruskal)(基础)

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370


题意:

首先给一个t,代表t个测试样例,再给一个n,表示有n个QS装置,接下来一行是n个QS装置的成本。接下来是n*n的矩阵,表示每两个QS 装置之间链接需要的费用。求在全联通的情况下求最少费用。

思路:

直接kruskal,注意在记录两个装置之间的权值时直接加上两个装置的成本就好了。不要最后求和再加!

代码:

//12004 KB	210 ms
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int inf=0xfffffff;

typedef struct node
{
    int l,r;
    int w;
    bool operator < (const node &a) const
    {
        return w<a.w;
    }
}node;
node p[1000010];
int pre[1010],dis[1010],qs[1010];
int num,n;

int Find(int x)
{
    return pre[x]==x?pre[x]:Find(pre[x]);
}

int Union(int a,int b)
{
    int f1=Find(a),f2=Find(b);
    if(f1!=f2)
    {
        pre[f1]=f2;
        return 1;
    }
    return 0;
}

void kruskal()
{
    int sum=0;
    for(int i=0;i<num;i++)
    {
        if(!Union(p[i].l,p[i].r))
            continue;
        sum=sum+p[i].w;
    }
    printf("%d\n",sum);
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        num=0;
        scanf("%d",&n);
        for(int i=0;i<=n;i++)
            pre[i]=i;
        for(int i=1;i<=n;i++)
            scanf("%d",&qs[i]);
        int val;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                p[num].l=i;
                p[num].r=j;
                scanf("%d",&val);
                p[num++].w=val+qs[i]+qs[j];
            }
        }
        sort(p,p+num);
        kruskal();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值