1012. The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


查询若干个学生的最好的排名和对应的科目。用map储存学生信息方便查找,同时用vector储存信息,方便用sort函数排序。注意如果两个科目排名一样,则按照A>C>M>E的优先级别来选择。另外对于同一科目的排名,如果同分则排名相同


代码:

#include <iostream>
#include <cstring>
#include <vector>
#include <map>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

struct student
{
	string id;
	double a;
	double c;
	double m;
	double e;
	int a_rank;
	int c_rank;
	int m_rank;
	int e_rank;
};

bool cmp1(const student &s1,const student &s2)
{
	return s1.a>s2.a;
}

bool cmp2(const student &s1,const student &s2)
{
	return s1.c>s2.c;
}

bool cmp3(const student &s1,const student &s2)
{
	return s1.m>s2.m;
}

bool cmp4(const student &s1,const student &s2)
{
	return s1.e>s2.e;
}

int main()
{
	int n,m;
	cin>>n>>m;
	map<string,student>stu;
	vector<student>vec(n);
	for(int i=0;i<n;i++)
	{
		string id;
		double c,m,e,a;
		cin>>id;
		stu[id].id=id;
		cin>>c>>m>>e;
		stu[id].c=c;stu[id].m=m;stu[id].e=e;
		a=(c+m+e)/3;
		stu[id].a=a;
		
		vec[i].id=id;
		vec[i].a=a;vec[i].c=c;vec[i].m=m;vec[i].e=e;
	}

	sort(vec.begin(),vec.end(),cmp1);
	stu[vec[0].id].a_rank=1;
	int rank=1;
	for(int i=1;i<n;i++)
	{
		string id =vec[i].id;
		if(stu[id].a<stu[vec[i-1].id].a) rank=i+1;
		stu[id].a_rank=rank;
	}

	sort(vec.begin(),vec.end(),cmp2);
	stu[vec[0].id].c_rank=1;
	rank=1;
	for(int i=1;i<n;i++)
	{
		string id =vec[i].id;
		if(stu[id].c<stu[vec[i-1].id].c) rank=i+1;
		stu[id].c_rank=rank;
	}

	sort(vec.begin(),vec.end(),cmp3);
	stu[vec[0].id].m_rank=1;
	rank=1;
	for(int i=1;i<n;i++)
	{
		string id =vec[i].id;
		if(stu[id].m<stu[vec[i-1].id].m) rank=i+1;
		stu[id].m_rank=rank;
	}

	sort(vec.begin(),vec.end(),cmp4);
	stu[vec[0].id].e_rank=1;
	rank=1;
	for(int i=1;i<n;i++)
	{
		string id =vec[i].id;
		if(stu[id].e<stu[vec[i-1].id].e) rank=i+1;
		stu[id].e_rank=rank;
	}

	for(int i=0;i<m;i++)
	{
		string id;
		cin>>id;
		if(stu.find(id)==stu.end()) 
		{
			cout<<"N/A"<<endl;
		}
		else
		{
			if((stu[id].a_rank<=stu[id].c_rank)&&(stu[id].a_rank<=stu[id].m_rank)&&(stu[id].a_rank<=stu[id].e_rank))
				cout<<stu[id].a_rank<<" "<<"A"<<endl;
			else if((stu[id].c_rank<stu[id].a_rank)&&(stu[id].c_rank<=stu[id].m_rank)&&(stu[id].c_rank<=stu[id].e_rank))
				cout<<stu[id].c_rank<<" "<<"C"<<endl;
			else if((stu[id].m_rank<stu[id].a_rank)&&(stu[id].m_rank<stu[id].c_rank)&&(stu[id].m_rank<=stu[id].e_rank))
				cout<<stu[id].m_rank<<" "<<"M"<<endl;
			else cout<<stu[id].e_rank<<" "<<"E"<<endl;
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值