1096. Consecutive Factors (20)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7

求一个数n连续的因子,要求使得因子数最多且使因子尽量小。2的31次方等于2 147 483 648,而12的阶乘为479 001 600,13的阶乘是6 227 020 800,故最大的连续因子数为12,因此可以暴力破之。需要注意的是连续因子数小于2时,即没有因子是连续的情况,如果数n是合数就输出最小的因子;如果n是素数就输出该数(因为1不能是答案)。


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <cmath>
using namespace std;

int main()
{
	long long n;
	cin>>n;
	
	for(int num=11;num>1;num--)
	{
		for(int i=2;i+num<=13;i++)
		{
			long long m=1;
			for(int j=i;j<i+num;j++)
			{
				m*=j;
			}
			if(n%m==0)
			{
				printf("%d\n%d",num,i);
				for(int j=i+1;j<i+num;j++)
				{
					printf("*%d",j);
				}
				return 0;
			}
		}
	}
	for(int i=2;i<=sqrt(n);i++)
	{
		if(n%i==0) 
		{
			printf("1\n%d",i);
			return 0;
		}
	}
	printf("1\n%d",n);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值