1044. Shopping in Mars (25)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5

题目相当于找出给出的序列中的连续子序列,使其和大于或等于给定的数值m,且使得m最小。同时更新子序列的左右端索引:先让右端索引增加,直到子序列的和刚好大于或等于m,更新大于或等于m的最小的和值,且更新答案;然后收缩,让左端索引增加,直到子序列的和小于m,然后左端索引减1(这样子序列的和就能大于或等于m),这里要注意可能左端索引没变,所以如果没变就忽略之;如果变了,就更新大于或等于m的最小的和值,且更新答案。然后左端索引加1,继续循环,直到右端索引指向最后的值。


代码:

#include <iostream>
#include <cstring>
#include <vector>
#include <cstdlib>
#include <cstdio>
using namespace std;

int main()
{
	int n,m;
	scanf("%d %d",&n,&m);
	vector<int>sum(n+1,0);
	for(int i=0;i<n;i++)
	{
		int d;
		scanf("%d",&d);
		sum[i+1]=sum[i]+d;
	}
	vector<pair<int,int> >res;
	int Best=1<<30;
	for(int i=0;i<n+1;i++)
	{
		int j;
		for(j=i+1;j<n+1;j++)
		{
			if((sum[j]-sum[i])>=m)
			{
				if((sum[j]-sum[i])<Best)
				{
					Best=sum[j]-sum[i];
					res.clear();
					res.push_back(pair<int,int>(i+1,j));
				}
				else if((sum[j]-sum[i])==Best)
				{
					res.push_back(pair<int,int>(i+1,j));
				}
				break;
			}
		}
		int save=i;
		while((sum[j]-sum[++i])>=m);
		i--;
		if((sum[j]-sum[i])==Best&&save!=i)
		{
			res.push_back(pair<int,int>(i+1,j));
		}
		else if((sum[j]-sum[i])<Best&&save!=i)
		{
			Best=sum[j]-sum[i];
			res.clear();
			res.push_back(pair<int,int>(i+1,j));
		}
		if(j==n) break;
	}
	for(int i=0;i<res.size();i++)
	{
		printf("%d-%d\n",res[i].first,res[i].second);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值