1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

给出一个环和其中相邻点之间的距离,求指定的两点之间的最短距离。两点之间,走法只有两种,即顺时针和逆时针走两种走法,选使得路径最短的那种就行了。输入的时候计算环的总长度sum,同时保存点1到各个点的距离dis[i](i表示当前点)。然后输入需要查找的两个点x和y,使x小于y(如果x大于y则互换),用dis[y]减去dis[x]即可得到x到y的顺时针距离,然后sum减去顺时针距离就得到逆时针距离,然后他们之间的最小值就是答案。


代码:

#include <iostream>
#include <cstring>
#include <vector>
#include <cstdio>
#include <cstdlib>
using namespace std;

int main()
{
	int n;
	cin>>n;
	vector<int>dis(n+1);
	int sum=0;
	for(int i=1;i<=n;i++)
	{
		int d;
		cin>>d;
		sum+=d;
		if(i==n) break;
		dis[i+1]=dis[i]+d;
	}
	int m;
	cin>>m;
	for(int i=0;i<m;i++)
	{
		int x,y;
		cin>>x>>y;
		if(x>y) swap(x,y);
		int res=min((dis[y]-dis[x]),sum-(dis[y]-dis[x]));
		cout<<res<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值