1047. Student List for Course (25)

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

这道题类似39题,不同的是39题给出课程信息要求得到学生信息,这里是根据学生信息得到课程信息。一开始的做法是将学生名字加到对应课程的vector数组中,然后对每门课程,将对应的学生姓名排序,然后输出。这样做最后一个case会超时,可能是因为字符串的排序比较耗时间。于是将学生名字转成正整数(一一对应)储存到对应课程的vector数组。然后排序的时候是对正整数排序,再依次将正整数转成学生名字输出即可。


代码:

#include <iostream>
#include <cstring>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
	int n,m;
	scanf("%d %d",&n,&m);
	vector<vector<int> >course(m+1);
	for(int i=0;i<n;i++)
	{
		char name[4];
		int k;
		scanf("%s %d",name,&k);
		int key=(name[0]-'A')*26*26*10+(name[1]-'A')*26*10+(name[2]-'A')*10+(name[3]-'0');
		for(int j=0;j<k;j++)
		{
			int c;
			cin>>c;
			course[c].push_back(key);
		}
	}
	for(int i=1;i<=m;i++)
	{
		int s=course[i].size();
		printf("%d %d\n",i,s);
		sort(course[i].begin(),course[i].end());
		for(int j=0;j<s;j++)
		{
			int key=course[i][j];
			char name[4];
			name[0]=key/(26*26*10)+'A';
			key%=(26*26*10);
			name[1]=key/(26*10)+'A';
			key%=(26*10);
			name[2]=key/(10)+'A';
			name[3]=key%10+'0';
			printf("%s\n",name);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值