1095. Cars on Campus (30)

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each "in" record is paired with the chronologically next record for the same car provided it is an "out" record. Any "in" records that are not paired with an "out" record are ignored, as are "out" records not paired with an "in" record. It is guaranteed that at least one car is well paired in the input, and no car is both "in" and "out" at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

求某个时刻在校园里面车的数量以及一天中在校园里时间最久的车和对应的时间。题目规定要in和out匹配成一对才是有效的记录,即同一辆车相邻的in和out记录才是有效的,其他的都不用计算。所以要先判断哪些记录是有效的。然后根据有效的记录,计算在记录中的各个时刻,分别有多少辆车在校园,计算方法是状态是in的加1,是out的就减一。同时也更新每辆车在校的时间和更新在校时间最大值。最后对于每个要搜索的时刻,在上面有效记录中,找出最靠近且小于这个时刻的时刻,其对应的在校车辆数就是当前要搜索的时刻的在校车辆数。最后找出在校时间和最大在校时间一样的车辆,输出即可。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;

struct data
{
	string plate;
	int time;
	int state;
};

struct car
{
	int in_time;
	int total;
};

bool cmp(const data &d1,const data &d2)
{
	return d1.time<d2.time;
}

int get_time(string t)
{
	int h=atoi(t.substr(0,2).c_str());
	int m=atoi(t.substr(3,2).c_str());
	int s=atoi(t.substr(6,2).c_str());
	return h*3600+m*60+s;
}

int print_time(int time)
{
	int h=time/3600;
	time=time%3600;
	int m=time/60;
	time=time%60;
	printf("%02d:%02d:%02d\n",h,m,time);
}

int main()
{
	int n,m;
	cin>>n>>m;
	vector<data>d(n);
	for(int i=0;i<n;i++)
	{
		string t,s;
		cin>>d[i].plate>>t>>s;
		d[i].time=get_time(t);
		d[i].state=(s=="in")?1:0;
	}
	sort(d.begin(),d.end(),cmp);
	
	vector<bool>isvalid(n,false);
	map<string,int>in_idx;
	map<string,int>::iterator it0;
	for(int i=0;i<n;i++)
	{
		it0=in_idx.find(d[i].plate);
		if(d[i].state==0&&it0!=in_idx.end())
		{
			isvalid[i]=isvalid[it0->second]=true;
			in_idx.erase(it0);
		}
		else if(d[i].state==1)
		{
			in_idx[d[i].plate]=i;
		}
	}
	
	map<string,car>cars;
	map<string,car>::iterator it;
	map<int,int>count;
	count[0]=0;
	int last_count=0;
	int i=0,j;
	int Max=0;
	
	while(i<n)
	{
		count[d[i].time]=last_count;
		for(j=i;j<n;j++)
		{
			if(d[j].time!=d[i].time)
			{
				break;
			}
			if(!isvalid[j]) continue;
			if(d[j].state==1) 
			{
				count[d[j].time]++;
				cars[d[j].plate].in_time=d[j].time;
			}
			else if(d[j].state==0)
			{
				count[d[j].time]--;
				it=cars.find(d[j].plate);
				(it->second).total+=(d[j].time-(it->second).in_time);
				Max=max(Max,(it->second).total);
			}
		}
		last_count=count[d[i].time];
		i=j;
	}
	
	map<int,int>::iterator it1=count.begin();
	for(i=0;i<m;i++)
	{
		char s[9];
		scanf("%s",s);
		string t(s);
		int time=get_time(t);
		for(it1++;it1!=count.end();it1++)
		{
			if(it1->first>time) break;
		}
		it1--;
		printf("%d\n",it1->second);
	}
	vector<string>res;
	for(it=cars.begin();it!=cars.end();it++)
	{
		if((it->second).total==Max)
		{
			res.push_back(it->first);
		}
	}
	for(i=0;i<res.size();i++)
	{
		cout<<res[i]<<" ";
	}
	print_time(Max);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值