POJ 2250 Compromise(最长公共子序列)

Compromise
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6750 Accepted: 3018 Special Judge

Description

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

Therefore the German government requires a program for the following task: 
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases. 
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden





思路:经典的dp问题,我用map把字符串数组映射成了int数组,然后递归打印解即可


#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

#include<map>
map<string,int> all;
char s[50];
int s1[110],s2[110];
int dp[110][110];
string ache[220];
int DP(int x,int y)
{
    if(x<0||y<0) return 0;
    int &ans=dp[x][y];
    if(dp[x][y]>=0) return ans;
    if(s1[x]==s2[y]) ans=DP(x-1,y-1)+1;
    else return ans=max(DP(x-1,y),DP(x,y-1));
    return ans;
}
void print(int x,int y)
{
    if(x<0||y<0) return ;
    if(s1[x]==s2[y])
    {
        print(x-1,y-1);
        if(DP(x,y)==1) cout<<ache[s1[x]];
        else cout<<' '<<ache[s1[x]];

    }
    else
    {
        if(DP(x,y-1)>DP(x-1,y)) print(x,y-1);
        else print(x-1,y);
    }
}
void ini()
{
    memset(dp,-1,sizeof(dp));
    all.clear();
}
int main()
{
    while(~scanf("%s",s))
    {
        ini();
        if(s[0]=='#') continue;
        int top=0;
        int l1=0,l2=0;
        string t=s;
        if(all.count(t)==0)
            all[t]=++top,ache[top]=t;
        s1[l1++]=all[t];
        while(scanf("%s",s))
        {
            if(s[0]=='#') break;
            t=s;
            if(all.count(t)==0) all[t]=++top,ache[top]=t;
            s1[l1++]=all[t];
        }
        while(scanf("%s",s))
        {
            if(s[0]=='#') break;
            t=s;
            if(all.count(t)==0) all[t]=++top,ache[top]=t;
            s2[l2++]=all[t];
        }
        dp[0][0]=(s1[0]==s2[0]);
        DP(l1-1,l2-1);
        print(l1-1,l2-1);
        puts("");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值