你现在在咸鱼商店,你有M元钱。咸鱼商店有N个物品,每个物品有两个属性,一个是他的价格S[i],另外一个是他的价值V[i]。现在你想买一些物品,使得这些物品的价值和大于等于K,并且使得其中价值最低的商品的价值尽量高。请你输出这个最大价值。
INPUT
第一行三个整数N,M,K。接下来N行,每行两个整数S和V,分别表示价格和价值。满足:1 <= N, M, S <= 10^3, 0 <= V, K <= 10^6
OUTPUT
输出价值最低的商品能够达到的最大价值。如果无解,输出-1
SAMPLE INPUT
3 10 11 210 15 5
SAMPLE OUTPUT
5
SOLUTION
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n,m,k;
struct node
{
int s,v;
bool operator < (const node &x) const{
if(x.v==v)
return s<x.s;
return v>x.v;
}
} f[1005];
int main()
{
while(~scanf("%d %d %d",&n,&m,&k))
{
for(int i=0;i<n;i++)
scanf("%d %d",&f[i].s,&f[i].v);
sort(f,f+n);
int ok=-1;
int ans=0,anv=0;
for(int i=0;i<n;i++)
{
if(ans+f[i].s<=m)
{
if(anv+f[i].v>=k)
{
printf("%d\n",anv+f[i].v);
ok=1;
break;
}
else
{
ans=ans+f[i].s;
anv=anv+f[i].v;
}
}
}
if(ok==-1)
printf("-1\n");
}
return 0;
}