算法入门经典二叉树DFS题目UVA548 Tree

问题描述:给一棵点带权的二叉树的中序和后序遍历,找一个叶子使得到它的根的路径上的权和最小。输入中没两行表示一棵树,第一行为中序遍历,第二行为后序遍历。
样例输入:
3 2 1 4 5 7 6
3 1 2 5 6 7 4
样例输出:
1
分析一下:此题有两个难点,1.如何根据二叉树的中序遍历和后序遍历构造出这个树。2.如果这个树构造完成,如何实现找一个叶子使得到它的根的路径权和最小。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<sstream>
using namespace std;
const int maxn = 10000+10;
int in_order[maxn],post_order[maxn],lch[maxn],rch[maxn];
int n;

bool input_read(int*a)
{
    string line;
    if(!getline(cin,line)) return false;
    stringstream ss(line);
    n=0;
    int x;
    while(ss>>x) a[n++] = x;//将这个字符串中每个数字存入a数组中
    return n>0;
} 

int build(int L1,int R1,int L2,int R2){
    if(L1>R1) return 0;
    int root = post_order[R2];            //取根结点 
    int p = L1;
    while(in_order[p]!=root) p++;
    int cnt = p-L1;                       //左子树的结点个数
    lch[root] = build(L1,p-1,L2,L2+cnt-1);//下一个左子树的根结点的位置
    rch[root] = build(p+1,R1,L2+cnt,R2-1);//下一个右子数的根结点的位置 
    return root;
}

int best,best_sum;//目前为止的最优解 

void dfs(int u,int sum)
{
    sum += u;
    if(!lch[u]&&!rch[u]){
        if(sum<best_sum||(sum == best_sum && u < best)){
            best = u; best_sum = sum;
        }
    }
    if(lch[u]) dfs(lch[u],sum);
    if(rch[u]) dfs(rch[u],sum);
}

int main()
{
    while(input_read(in_order)){
        input_read(post_order); 
        build(0,n-1,0,n-1);
        best_sum = 1000000000;
        dfs(post_order[n-1],0);//从根结点开始遍历
        cout<<best<<endl; 
    }
    return 0;
}     

如何根据二叉树的后序和中序遍历构造出这棵树?
如何根据二叉树的前序和中序遍历构造出这棵树?

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值