HDU 2817 A sequence of numbers (数学+快速幂)

37 篇文章 3 订阅
25 篇文章 0 订阅

Problem Description

Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.


Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.


Output
Output one line for each test case, that is, the K-th number module (%) 200907.


Sample Input
2
1 2 3 5
1 2 4 5


Sample Output
5
16


Source

2009 Multi-University Training Contest 1 - Host by TJU

题意: 

    给你数列的前三个数a、b、c,判断这个数列是等差数列还是等比数列,然后求数列的第K个值,,,最后对200907取模,

思路:

  先根据前三个数判断数列,再用等差或者等比数列公式求第k个值,,取模需要使用快速幂。。

以下AC代码:


#include<stdio.h>
#define mod 200907
long long QucikMod(long long a,long long b)
{
    long long temp=1;
    a=a%mod;
    while(b>0)
    {
        if(b%2==1)
        temp=(temp*a)%mod;
        b=b/2;
        a=(a*a)%mod;
    }
    return temp;
}
int main()
{
    long long t,a,b,c,q,d,k,sum;
    scanf("%I64d",&t);
    while(t--)
    {
    scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k);
    if(c-b==b-a)
    {
        d=b-a;
        sum=(a%mod+(k-1)*d%mod)%mod;
    }
    else
    {
        q=b/a;
        sum=a*QucikMod(q,k-1)%mod;
    }
    printf("%I64d\n",sum);
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值