UVa 10382 Watering Grass 解题报告(贪心 最小覆盖)

56 篇文章 0 订阅

Problem E
Watering Grass
Input:
 standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbers nl and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

 

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

 

Sample Output

6

2

-1


    解题报告: 在DP N次WA后,我看了解题报告。原来就是赤果果的贪心啊。简单来说,就是每次找最右!

    代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <string>
using namespace std;

#define ff(i, n) for(int i=0;i<(n);i++)
#define fff(i, n, m) for(int i=(n);i<=(m);i++)
#define dff(i, n, m) for(int i=(n);i>=(m);i--)
typedef long long LL;
typedef unsigned long long ULL;
void work();

int main()
{
#ifdef ACM
    freopen("in.txt", "r", stdin);
#endif // ACM

    work();
}

///
struct Node
{
    double sta;
    double end;
    bool operator<(const Node & cmp) const
    {
        return sta < cmp.sta;
    }
} node[11111];

void work()
{
    int n;
    double l, w;
    while(~scanf("%d%lf%lf", &n, &l, &w))
    {
        int tot=0;

        ff(i, n)
        {
            double pos, r;
            scanf("%lf%lf", &pos, &r);
            if(2*r <= w) continue;

            double a = sqrt(r*r-w*w/4.0);
            node[tot].sta = pos-a;
            node[tot].end = pos+a;
            tot++;
        }
        sort(node, node+tot);

        double left = 0, right = 0;
        bool flag = false;
        int cnt = 0;

        if(tot && node[0].sta<=0) ff(a, tot)
        {
            bool found = false;
            for(int b=a; b<tot && node[b].sta <= left; b++)
            {
                a = b;

                if(right <= node[b].end)
                    right = node[b].end, found = true;
            }

            if(!found) break;

            cnt++;
            left = right;
            if(left>=l)
            {
                flag = true;
                break;
            }
        }

        if(!flag) cnt = -1;
        printf("%d\n", cnt);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值