POJ 2361 Tic Tac Toe 模拟

Tic Tac Toe
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1992 Accepted: 750

Description

Tic Tac Toe is a child's game played on a 3 by 3 grid. One player, X, starts by placing an X at an unoccupied grid position. Then the other player, O, places an O at an unoccupied grid position. Play alternates between X and O until the grid is filled or one player's symbols occupy an entire line (vertical, horizontal, or diagonal) in the grid. 
We will denote the initial empty Tic Tac Toe grid with nine dots. Whenever X or O plays we fill in an X or an O in the appropriate position. The example below illustrates each grid configuration from the beginning to the end of a game in which X wins. 
...  X..  X.O  X.O  X.O  X.O  X.O  X.O

...  ...  ...  ...  .O.  .O.  OO.  OO.

...  ...  ...  ..X  ..X  X.X  X.X  XXX

Your job is to read a grid and to determine whether or not it could possibly be part of a valid Tic Tac Toe game. That is, is there a series of plays that can yield this grid somewhere between the start and end of the game?

Input

The first line of input contains N, the number of test cases. 4N-1 lines follow, specifying N grid configurations separated by empty lines.

Output

For each case print "yes" or "no" on a line by itself, indicating whether or not the configuration could be part of a Tic Tac Toe game.

Sample Input

2
X.O
OO.
XXX

O.X
XX.
OOO

Sample Output

yes
no

Source


#include <iostream>
using namespace std;
int main()
{
	string a[4];
	int f,n,wo,wx,no,nx,i,j;
	cin>>n;
	while (n--){
		wo=wx=no=nx=0; f=1;
		for (i=0;i<3;++i)
			cin>>a[i];
		for (i=0;i<3;++i)
			for (j=0;j<3;++j){
				if (a[i][j]=='O')
					no++;
				if (a[i][j]=='X')
					nx++;
			}
				
	
		if (a[0][0]==a[0][1] && a[0][1]==a[0][2]){
			if (a[0][1]=='O') wo=1;
			if (a[0][1]=='X') wx=1;
		}
		if (a[1][0]==a[1][1] && a[1][1]==a[1][2]){
			if (a[1][1]=='O') wo=1;
			if (a[1][1]=='X') wx=1;
		}
		if (a[2][0]==a[2][1] && a[2][1]==a[2][2]){
			if (a[2][1]=='O') wo=1;
			if (a[2][1]=='X') wx=1;
		}
		if (a[0][0]==a[1][0] && a[1][0]==a[2][0]){
			if (a[1][0]=='O') wo=1;
			if (a[1][0]=='X') wx=1;
		}
		if (a[0][1]==a[1][1] && a[1][1]==a[2][1]){
			if (a[1][1]=='O') wo=1;
			if (a[1][1]=='X') wx=1;
		}
		if (a[0][2]==a[1][2] && a[1][2]==a[2][2]){
			if (a[1][2]=='O') wo=1;
			if (a[1][2]=='X') wx=1;
		}
		if (a[0][0]==a[1][1] && a[1][1]==a[2][2]){
			if (a[1][1]=='O') wo=1;
			if (a[1][1]=='X') wx=1;
		}
		if (a[0][2]==a[1][1] && a[1][1]==a[2][0]){
			if (a[1][1]=='O') wo=1;
			if (a[1][1]=='X') wx=1;
		}
		
		if (no>nx) f=0;
		if (nx-no>=2) f=0;
		if (wo && wx) f=0;
		if (wo && no!=nx) f=0;
		if (wx && no==nx) f=0;
		
		if (f)
			cout<<"yes\n";
		else
			cout<<"no\n";
		
	}
	return 0;
} 

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值