HDOJ 1009 FatMouse' Trade


FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29318    Accepted Submission(s): 9449


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
 

Source
 

Recommend
JGShining
 

题目描述:一只肥鼠准备了M磅猫粮,打算和猫做交易,换取它最喜欢的食物“爪哇咖啡豆”。现已知仓库有N间房间,房间的i-th包含J[i]磅的和F[i]磅的猫粮。肥鼠可能不会交易某间房的所有食物,相反,他可能会J[i]* %磅的“爪哇咖啡豆”换取F[i]* %磅的猫粮。求肥鼠最多能得到多少“爪哇咖啡豆”。

部分背包(贪心)

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz

#include <iostream>
using namespace std;
struct house{
	int j,f;
	double ii;
};
int cmp(house,house); 
house a[1100];
int m,n,i,f,j; double bean;
int main(int argc, char *argv[])
{
	cout.precision(3);
	cout.setf(ios::fixed);
	while((cin>>m>>n)&&(m!=-1)){
 		for (i=1;i<=n;++i){
			cin>>a[i].j>>a[i].f;
			if (!a[i].f) a[i].ii=1001;
			else a[i].ii=(double)a[i].j/(double)a[i].f;
 		} 
		i=1; bean=0; j=m;
		sort(a+1,a+n+1,cmp);
		while ((j)&&(i<=n)){
			if (a[i].ii>1000) bean+=a[i].j;
			else if(a[i].f>j){
				bean+=j*a[i].ii; j=0;
			}
			else{
				bean+=a[i].j; j-=a[i].f;
			}
			++i;
		}
		cout<<bean<<endl;
	}
	return 0;
}

int cmp(house a,house b){
	return a.ii>b.ii;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值