Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2



问题分析

    这道题找的是口袋的数目(在一处油藏的八个方向有油藏算作一个口袋),依旧是深搜,搜到一处油藏‘@’,就找整个口袋并全部赋为‘*’。




代码如下

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 100 + 5;

char map[MAX][MAX];
int M, N, sum;
int dx[8] = {1, 1, 1, -1, -1, -1, 0, 0};
int dy[8] = {1, 0, -1, 1, 0, -1, 1, -1};

void DFS(int x, int y)
{
	for(int i = 0; i < 8; i++){//确定油藏的口袋大小 
		int tx = x + dx[i];
		int ty = y + dy[i];
		if(tx <= M && tx > 0 && ty <= N && ty > 0 && map[tx][ty] == '@'){//判断条件十分关键,特别注意 
			map[tx][ty] = '*';//只发现一次,避免了死循环 
			DFS(tx, ty);//将一片油藏全部发现,也就全部变为了* 
		}
	}
}

int main()
{
	int x, y;
	while(scanf("%d%d", &M, &N) != EOF && M){
		sum = 0; 
		for(int i = 1; i <= M; i++)
			for(int j = 1; j <= N; j++)
				cin >> map[i][j];//输入字符用cin不容易出错,scanf要注意空格问题 
		for(int i = 1; i <= M; i++)
			for(int j = 1; j <= N; j++)
				if(map[i][j] == '@'){
					sum++;//发现一处油藏 
					map[i][j] = '*'; 
					DFS(i, j);
				}
		printf("%d\n", sum);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值