Catch That Cow

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input Line 1: Two space-separated integers: N and K Output Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow. Sample Input
5 17
Sample Output
4 





 
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.





问题分析

    这道题是一道经典的广搜的题,由于只有三种走法,分步广搜即可。这里我用到了STL里面的queue。(STL真是好东西,用好了可以简化很多操作)。

    注意两个细节:

    最大的距离不能够超过所给数据范围的2倍。因为一旦超过,就一定不是最少步数的走法(不明白的读者可以自己推导一下)。

    人和牛可能在0号点,这就要求越界判断更加严谨(笔者就是这里错误了几次)。




代码如下

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
const int MAX = 200000 + 5;//最大不超过100000的2倍 

bool mark[MAX];//用来判断该点走过与否 
int N, K;
struct Node{
	int place, step; //分别表示农夫的位置和已经走的步数 
};

bool exist(int x)//判断是否符合要求(没有越界,没有走过) 
{
	if(x > -1 && x < MAX && !mark[x])//仔细看题,不难发现,牛可能在0点,因此x>-1,严谨的保证正确 
		return 1;
	return 0;
}

int BFS()
{
	queue<Node> Q;
	Node here, next;
	here.place = N;
	here.step = 0;
	mark[here.place] = true;
	Q.push(here);
	while(!Q.empty()){
		here = Q.front();
		Q.pop();
		if(here.place == K)//农夫找到了牛 
			return here.step;
		next = here;
		//开始分情况讨论 
		next.place = here.place + 1;
		if(exist(next.place)){
			next.step = here.step + 1;//步数加1 
			mark[next.place] = true;//已经走过 
			Q.push(next);
		}
		next.place = here.place - 1;
		if(exist(next.place)){
			next.step = here.step + 1;
			mark[next.place] = true;
			Q.push(next);
		}
		next.place = here.place * 2;
		if(exist(next.place)){
			next.step = here.step + 1;
			mark[next.place] = true;
			Q.push(next);
		}
	}
}

int main()
{
	while(scanf("%d%d", &N, &K) != EOF){
		memset(mark, false ,sizeof(mark));
		printf("%d\n", BFS());
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
对于计算机专业的学生而言,参加各类比赛能够带来多方面的益处,具体包括但不限于以下几点: 技能提升: 参与比赛促使学生深入学习和掌握计算机领域的专业知识与技能,如编程语言、算法设计、软件工程、网络安全等。 比赛通常涉及实际问题的解决,有助于将理论知识应用于实践中,增强问题解决能力。 实践经验: 大多数比赛都要求参赛者设计并实现解决方案,这提供了宝贵的动手操作机会,有助于积累项目经验。 实践经验对于计算机专业的学生尤为重要,因为雇主往往更青睐有实际项目背景的候选人。 团队合作: 许多比赛鼓励团队协作,这有助于培养学生的团队精神、沟通技巧和领导能力。 团队合作还能促进学生之间的知识共享和思维碰撞,有助于形成更全面的解决方案。 职业发展: 获奖经历可以显著增强简历的吸引力,为求职或继续深造提供有力支持。 某些比赛可能直接与企业合作,提供实习、工作机会或奖学金,为学生的职业生涯打开更多门路。 网络拓展: 比赛是结识同行业人才的好机会,可以帮助学生建立行业联系,这对于未来的职业发展非常重要。 奖金与荣誉: 许多比赛提供奖金或奖品,这不仅能给予学生经济上的奖励,还能增强其成就感和自信心。 荣誉证书或奖状可以证明学生的成就,对个人品牌建设有积极作用。 创新与研究: 参加比赛可以激发学生的创新思维,推动科研项目的开展,有时甚至能促成学术论文的发表。 个人成长: 在准备和参加比赛的过程中,学生将面临压力与挑战,这有助于培养良好的心理素质和抗压能力。 自我挑战和克服困难的经历对个人成长有着深远的影响。 综上所述,参加计算机领域的比赛对于学生来说是一个全面发展的平台,不仅可以提升专业技能,还能增强团队协作、沟通、解决问题的能力,并为未来的职业生涯奠定坚实的基础。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值