Red and Black

 There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
Output
    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

Sample Output

    45
    59
    6
    13





问题分析

    基础题目,直接深搜,注意找的是块数而不是步数,因此不用后退。





代码如下:

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 20 + 5;

bool mark[MAX][MAX];
char map[MAX][MAX];
int W, H, sum;
int dx[4] = {1, -1, 0, 0};
int dy[4] = {0, 0, 1, -1};

void DFS(int x, int y)
{
	for(int i = 0; i < 4; i++){//向四个方向进行深搜 
		int tx = x + dx[i];
		int ty = y + dy[i];
		if(tx <= H && tx > 0 && ty <= W && ty > 0 && !mark[tx][ty]){//判断条件十分关键,特别注意 
			sum++;
			mark[tx][ty] = true;//走过了就不重复走了 
			DFS(tx, ty);//这里记的是块数而不是步数,不需要sum--的操作了 
		}
	}
}

int main()
{
	int x, y;
	while(scanf("%d%d", &W, &H) != EOF && W && H){
		sum = 1;//起点算作一块 
		memset(mark, false, sizeof(mark));
		for(int i = 1; i <= H; i++)
			for(int j = 1; j <= W; j++){
				cin >> map[i][j];//输入字符用cin不容易出错,scanf要注意空格问题 
				if(map[i][j] == '@'){
					x = i;
					y = j;
					mark[x][y] = true;//起点已经走过 
				}
				if(map[i][j] == '#')//不能走的直接算作走过,减少操作和内存 
					mark[i][j] = true;
			}
		DFS(x, y);
		printf("%d\n", sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值