COJ 1102 - You Can Say 11 题解

本题就是给出一个无穷大数,算其是否能被11除尽

Description

Your job is, given a positive number  N, determine if it is a multiple of eleven.

Input specification

The input is a file such that each line contains a positive number. A line containing the number 0 is the end of the input. The given numbers can contain up to 1000 digits.

Output specification

The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.

Sample input
112233
30800
2937
323455693
5038297
112234
0
Sample output
112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.

使用string模拟除法就可以了。

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

bool divEleven(string s)
{
	int carry = 0;
	for (int i = 0; i < s.size(); i++)
	{
		int d = carry * 10 + s[i] - '0';
		carry = d % 11;
	}
	if (carry) return false;
	return true;
}

void Eleven()
{
	string S;
	while (cin>>S && "0" != S)
	{
		if (divEleven(S)) cout<<S<<" is a multiple of 11.\n";
		else cout<<S<<" is not a multiple of 11.\n";
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值