poj 1007 逆序问题

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 62833 Accepted: 24799

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


解题关键在于计算逆序数和对逆序数的排序。

解法一:手工排序

#include <stdio.h>
#include <string.h>

int main(void)
{
	int temp,n,m,i,j,k,count[103]={0};
	char dna[103][103];
	scanf("%d %d",&m,&n);
	while (scanf(" ")||scanf("\n")) 		//清除中间的空格和回车
		;
	for(i=0;i<n;i++){						
		gets(dna[i]);				//取一条DNA
		for(j=0;j<m;j++){			//计算逆序数
			for(k=j+1;k<m;k++){
				if (dna[i][j]>dna[i][k]) count[i]++;
			}	
		}
		count[i]=count[i]*1000+i;		//合并逆序数和序号
		for(j=0;j<i;j++){			//排序
			if (count[i]<count[j]) break;
		}
		if(i!=j){				//如果不是最大数,则插入
			temp=count[i];
			for(k=i;k>j;k--){
				count[k]=count[k-1];
			}
			count[k]=temp;
		}
	}
	for(i=0;i<n;i++)				//输出
		puts(dna[count[i]%1000]);
	return 0;
}
结果:172kb    12ms

解法二:qsort排序

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int comp(const void *a,const void *b) 		//定义比较函数
{
return *(int *)a-*(int *)b; 
} 
int main(void)
{
	int temp,n,m,i,j,k,count[103]={0};
	char dna[103][103];
	scanf("%d %d",&m,&n);
	while (scanf(" ")||scanf("\n")) 		//清除中间的空格和回车
		;
	for(i=0;i<n;i++){						
		gets(dna[i]);						//取一条DNA
		for(j=0;j<m;j++){					
			for(k=j+1;k<m;k++){
				if (dna[i][j]>dna[i][k]) count[i]++;
			}	
		}
		count[i]=count[i]*1000+i;			//合并逆序数和序号
	}
	qsort(count,n,sizeof(int ),comp); 		//qsort排序函数
	for(i=0;i<n;i++)						//输出
		puts(dna[count[i]%1000]);
	return 0;
}
结果 172kb     16ms

总结:

开始做了好多遍,但是总是runtime error或者别的错误,后来仔细看看发现原来是数组开小了的原因。。在数据量小的情况下,手排和快排的速度差不多,看不出明显差别,但是据说快排在大量数据的时候就会相比下很慢。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值