USACO Section 1.5 Superprime Rib

题目原文

Superprime Rib

Butchering Farmer John's cows always yields the best prime rib. You can tell prime ribs by looking at the digits lovingly stamped across them, one by one, by FJ and the USDA. Farmer John ensures that a purchaser of his prime ribs gets really prime ribs because when sliced from the right, the numbers on the ribs continue to stay prime right down to the last rib, e.g.:

     7  3  3  1

The set of ribs denoted by 7331 is prime; the three ribs 733 are prime; the two ribs 73 are prime, and, of course, the last rib, 7, is prime. The number 7331 is called a superprime of length 4.

Write a program that accepts a number N 1 <=N<=8 of ribs and prints all the superprimes of that length.

The number 1 (by itself) is not a prime number.

PROGRAM NAME: sprime

INPUT FORMAT

A single line with the number N.

SAMPLE INPUT (file sprime.in)

4

OUTPUT FORMAT

The superprime ribs of length N, printed in ascending order one per line.

SAMPLE OUTPUT (file sprime.out)

2333
2339
2393
2399
2939
3119
3137
3733
3739
3793
3797
5939
7193
7331
7333
7393

分析

本题要求得到N位的超级质数,超级质数指的是,假设一个四位数abcd是质数,abc是质数,ab是质数,a也是质数,那么abcd就是四位的超级质数。
根据提议,只需要从左到右不断增加位数并且保证是质数就可以了。例如,一位的超级质数是2,3,5,7,在此基础上求两位的超级质数,得到23,27,31,37,59,71,73,然后求三位的、四位的,直到N位。

提交代码

/*
ID: 
PROG: sprime
LANG: C++
*/


#include <iostream>
#include <fstream>
#include <vector>
#include <algorithm>
#include <string>
#include <math.h>
using namespace std;

bool isPrime(int n)
{
	if(n==0 || n==1)
		return false;
	int d=2;
	while(d*d<=n)
	{
		if(n%d++==0)
			return false;
	}
	return true;
}


int main()
{
	ifstream fin("sprime.in");
	ofstream fout("sprime.out");

	int N;fin>>N;

	vector<int> sprime;
	sprime.push_back(2);
	sprime.push_back(3);
	sprime.push_back(5);
	sprime.push_back(7);
	for (int i=1;i!=N;i++)
	{
		vector<int> p;
		for (vector<int>::iterator itr = sprime.begin();itr!=sprime.end();++itr)
		{
			for (int j=1;j<10;j+=2)
			{
				if(isPrime(*itr*10 + j))
				{
					p.push_back(*itr*10+j);
				}
			}
		}
		sprime.clear();
		sprime = p;
	}

	for (int i=0;i!=sprime.size();i++)
	{
		fout << sprime[i] << endl;
	}

	
	return 0;
}


提交结果

TASK: sprime
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.003 secs, 3500 KB]
   Test 2: TEST OK [0.008 secs, 3500 KB]
   Test 3: TEST OK [0.014 secs, 3500 KB]
   Test 4: TEST OK [0.008 secs, 3500 KB]
   Test 5: TEST OK [0.014 secs, 3500 KB]

All tests OK.

Your program ('sprime') produced all correct answers! This is your submission #5 for this problem. Congratulations!


官方参考答案

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>

FILE *fout;

int
isprime(int n)
{
	int i;

	if(n == 2)
		return 1;

	if(n%2 == 0)
		return 0;

	for(i=3; i*i <= n; i+=2)
		if(n%i == 0)
			return 0;

	return 1;
}

/* print all sprimes possible by adding ndigit digits to the number n */
void
sprime(int n, int ndigit)
{
	if(ndigit == 0) {
		fprintf(fout, "%d\n", n);
		return;
	}

	n *= 10;
	if(isprime(n+1))
		sprime(n+1, ndigit-1);
	if(isprime(n+3))
		sprime(n+3, ndigit-1);
	if(isprime(n+7))
		sprime(n+7, ndigit-1);
	if(isprime(n+9))
		sprime(n+9, ndigit-1);
}

void
main(void)
{
	int n;
	FILE *fin;

	fin = fopen("sprime.in", "r");
	assert(fin != NULL);
	fout = fopen("sprime.out", "w");
	assert(fout != NULL);

	fscanf(fin, "%d", &n);

	sprime(2, n-1);
	sprime(3, n-1);
	sprime(5, n-1);
	sprime(7, n-1);
	exit (0);
}
官方答案通过递归实现,本文提交的代码是通过循环来实现,基本思想一致。

THE END


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值