USACO Section 2.1 Hamming Codes

题目原文

Hamming Codes
Rob Kolstad

Given N, B, and D: Find a set of N codewords (1 <= N <= 64), each of length B bits (1 <= B <= 8), such that each of the codewords is at least Hamming distance of D (1 <= D <= 7) away from each of the other codewords. The Hamming distance between a pair of codewords is the number of binary bits that differ in their binary notation. Consider the two codewords 0x554 and 0x234 and their differences (0x554 means the hexadecimal number with hex digits 5, 5, and 4):

        0x554 = 0101 0101 0100
        0x234 = 0010 0011 0100
Bit differences: xxx  xx

Since five bits were different, the Hamming distance is 5.

PROGRAM NAME: hamming

INPUT FORMAT

N, B, D on a single line

SAMPLE INPUT (file hamming.in)

16 7 3

OUTPUT FORMAT

N codewords, sorted, in decimal, ten per line. In the case of multiple solutions, your program should output the solution which, if interpreted as a base 2^B integer, would have the least value.

SAMPLE OUTPUT (file hamming.out)

0 7 25 30 42 45 51 52 75 76
82 85 97 102 120 127

分析

题目非常简单,直接从小到大枚举就可以了。计算两个整数的海明距离的时候,可以使用移位操作符来实现,具体代码如下:
int getHammingDistance(int a,int b)
{
	int dis=0;
	for (int i=0;i!=B;i++)
	{
		if((1<<i & a) != (1<<i & b))
			dis++;
	}
	return dis;
}


提交代码

/*
ID: 
PROG: hamming
LANG: C++
*/



#include <iostream>
#include <fstream>
#include <vector>
#include <algorithm>
#include <string>
#include <math.h>
#include <limits>
#include <map>
using namespace std;


int N,B,D;

int getHammingDistance(int a,int b)
{
	int dis=0;
	for (int i=0;i!=B;i++)
	{
		if((1<<i & a) != (1<<i & b))
			dis++;
	}
	return dis;
}


int main()
{
	ifstream cin("hamming.in");
	ofstream cout("hamming.out");


	cin >> N >> B >> D;

	vector<int> codes;
	
	codes.push_back(0);
	int temp=1;
	int count=1;
	while(count<N && temp<pow(2.0,B))
	{
		bool flag = true;
		for (int i=0;i!=codes.size();i++)
		{
			flag = flag && (getHammingDistance(temp,codes[i])>=D);
			if(!flag)
				break;
		}
		if(flag)
		{
			codes.push_back(temp);
			count++;
		}
		temp++;
	}

	for (int i=0;i!=codes.size()-1;i++)
	{
		cout << codes[i];
		if(i%10==9)
			cout <<endl;
		else
			cout << " ";
	}
	cout << codes[codes.size()-1] << endl;


	return 0;
}

提交结果

TASK: hamming
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.011 secs, 3500 KB]
   Test 2: TEST OK [0.008 secs, 3500 KB]
   Test 3: TEST OK [0.005 secs, 3500 KB]
   Test 4: TEST OK [0.008 secs, 3500 KB]
   Test 5: TEST OK [0.005 secs, 3500 KB]
   Test 6: TEST OK [0.005 secs, 3500 KB]
   Test 7: TEST OK [0.008 secs, 3500 KB]
   Test 8: TEST OK [0.008 secs, 3500 KB]
   Test 9: TEST OK [0.011 secs, 3500 KB]
   Test 10: TEST OK [0.005 secs, 3500 KB]
   Test 11: TEST OK [0.003 secs, 3500 KB]

All tests OK.

官方参考答案

#include <stdio.h>
#include <stdlib.h>
#include <iostream.h>
#define MAX (1 << 8 + 1)
#define NMAX 65
#define BMAX 10
#define DMAX 10

int nums[NMAX], dist[MAX][MAX];
int N, B, D, maxval;
FILE *in, *out;

void findgroups(int cur, int start) {
    int a, b, canuse;
    char ch;
    if (cur == N) {
        for (a = 0; a < cur; a++) {
            if (a % 10)
                fprintf(out, " ");
            fprintf(out, "%d", nums[a]);
            if (a % 10 == 9 || a == cur-1)
                fprintf(out, "\n");
        }
        exit(0);
    }
    for (a = start; a < maxval; a++) {
        canuse = 1;
        for (b = 0; b < cur; b++)
            if (dist[nums[b]][a] < D) {
                canuse = 0;
                break;
            }
        if (canuse) {
            nums[cur] = a;
            findgroups(cur+1, a+1);
        }
    }
}

int main() {
    in = fopen("hamming.in", "r");
    out = fopen("hamming.out", "w");
    int a, b, c;
    fscanf(in, "%d%d%d", &N, &B, &D);
    maxval = (1 << B);
    for (a = 0; a < maxval; a++)
        for (b = 0; b < maxval; b++) {
            dist[a][b] = 0;
            for (c = 0; c < B; c++) 
                if (((1 << c) & a) != ((1 << c) & b))
                    dist[a][b]++;
        }
    nums[0] = 0;
    findgroups(1, 1);
    return 0;
}

THE END

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值