树状数组解决!~~~~

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

?
1
2
3
4
5
6
7
8
9
10
11
12
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

?
1
2
3
4
1
0
0
1


思路:看到别人的代码才做出来的,感觉这种思想太厉害了,用2维树状数组来维护顶点出现的次数,每加入一个矩形,就把四个顶点加进去(注意边界问题,x2,y2要加一)。查询的时候就算出(1,1)到(x,y)的顶点的总数,奇数就为1,偶数就是0。


?
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
#include <stdio.h>
 
int sum[ 1005 ][ 1005 ],n,m;
 
int lowbit( int x)
{
     return x&-x;
}
 
void update( int x, int y)
{
     for ( int i=x;i<=n;i+=lowbit(i))
     {
         for ( int j=y;j<=n;j+=lowbit(j))
         {
             sum[i][j]++;
         }
     }
}
 
 
int query( int x, int y)
{
     int t= 0 ;
 
     for ( int i=x;i> 0 ;i-=lowbit(i))
     {
         for ( int j=y;j> 0 ;j-=lowbit(j))
         {
             t+=sum[i][j];
         }
     }
 
     return t& 1 ;
}
 
int main()
{
     int T,i,j,x1,y1,x2,y2;
     char s[ 5 ];
 
     scanf( "%d" ,&T);
 
     while (T--)
     {
         scanf( "%d%d" ,&n,&m);
 
         for (i= 1 ;i<=n;i++) for (j= 1 ;j<=n;j++) sum[i][j]= 0 ;
 
         while (m--)
         {
             scanf( "%s" ,s);
 
             if (s[ 0 ]== 'C' )
             {
                 scanf( "%d%d%d%d" ,&x1,&y1,&x2,&y2);
 
                 update(x1,y1);
                 update(x1,y2+ 1 );
                 update(x2+ 1 ,y2+ 1 );
                 update(x2+ 1 ,y1);
             }
             else
             {
                 scanf( "%d%d" ,&x1,&y1);
                 printf( "%d\n" ,query(x1,y1));
             }
         }
 
         printf( "\n" );
     }
}
</stdio.h>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值