poj 1094 Sorting It All Out

19 篇文章 0 订阅
Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 29594 Accepted: 10250

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source

给出一些大小关系,问是否矛盾或者无法确定或正确就输出

拓扑排序topsort

找一个度为0的点入队列,把和这个点所有相连的边都删掉,再重复操作,直到没有点的入度为0,如果当前队列的长度等于所有字母数,则输出,否则就会有问题。
我的代码里如果能排序成功就可以,没有看后续操作,还是有一点问题,居然能a。。



#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <math.h>
#include <vector>
#include <stdlib.h>
using namespace std;
int m,n,mp[30][30],in[30],q[30],flag;
int topsort()
{
	int cnt ,top=0,pos=0,flag=1,tmp[30];
	for(int i=1;i<=n;i++)
	{
		tmp[i]=in[i];
	}
	for(int i=1;i<=n;i++)
	{
		cnt=0;
		for(int j=1;j<=n;j++)
		{
			//cout<<tmp[j]<<endl;
			if(tmp[j]==0)
			{
				cnt++;
				pos=j;
			}
		}
		if(cnt==0) return 0;
		if(cnt>1) flag=-1;
		q[top++]=pos;
        tmp[pos]=-1;
        for(int j=1;j<=n;j++)
		{
			if(mp[pos][j]) tmp[j]--;
		}
	}
	return flag;
}
int main()
{
	char str[5];
	while(cin>>n>>m)
	{
		flag=0;
		if(m==0&&n==0) break;
		memset(mp,0,sizeof(mp));
		memset(in,0,sizeof(in));
		for(int i=1;i<=m;i++)
		{
			cin>>str;
			if(flag) continue;
			int a=str[0]-'A'+1;
			int b=str[2]-'A'+1;
			mp[a][b]=1;
			in[b]++;
			int s=topsort();
			if(s==0)
			{
				//cout<<"asdf";
				printf("Inconsistency found after %d relations.\n",i);
                flag=1;
			}
			if(s==1)
			{
				printf("Sorted sequence determined after %d relations: ",i);
                for(int j=0;j<n;j++)
                    printf("%c",q[j]+'A'-1);
                printf(".\n");
                flag=1;
			}
		}
		if(!flag) printf("Sorted sequence cannot be determined.\n");
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值