poj 3349 Snowflake Snow Snowflakes

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 33791 Accepted: 8853

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source


有n个6瓣的雪花,可以顺时针也可以逆时针旋转,对于每片花的每个花瓣和取mod之后,对应的值hash雪花记录一下。之后没进去一个新的雪花,先看有没有这个hash值 有了再判断是不是每瓣顺时针或者逆时针相等。没有hash值则直接插入,一直到最后

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <stdlib.h>
#include <math.h>
#include <set>
#include <map>
using namespace std;
#define Max 1200010
#define MOD 1200007
struct Node
{
	int num[6];
	int next;
};
Node node[Max];
int cur=0;
int hashtable[MOD];
void init()
{
	for(int i=0;i<=MOD;i++)
	{
		hashtable[i]=-1;
	}
}
int gethash(int *num)
{
	int hash=0;
	for(int i=0;i<6;i++)
	{
		hash+=num[i];
	}
	hash%=MOD;
	return hash;
}
bool cmp(int *num1 ,int *num2)
{
	for(int i=0;i<6;i++)
	{
		if(num1[i]!=num2[i]) return false;
	}
	return true;
}
void inserthash(int *num,int h)
{
	for(int i=0;i<6;i++)
	{
		node[cur].num[i]=num[i];
	}
	node[cur].next=hashtable[h];
	hashtable[h]=cur;
	cur++;
}
bool searchhash(int *num)
{
	int h=gethash(num);
	int next=hashtable[h];
	while(next!=-1)
	{
		if(cmp(num,node[next].num)) return true;
		next=node[next].next;
	}
	inserthash(num,h);
	return false;
}

int main()
{
	int num[2][12];
	int n;
	int flag=0;
	init();
	cin>>n;
	while(n--)
	{
		for(int i=0;i<6;i++)
		{
			scanf("%d",&num[0][i]);
			num[0][i+6]=num[0][i];
		}
		if(flag) continue;
		for(int i=0;i<6;i++)
		{
			num[1][i+6]=num[1][i]=num[0][5-i];
		}
		for(int i=0;i<6;i++)
		{
			if(searchhash(num[0]+i)||searchhash(num[1]+i)) {flag=1;break;}
		}
	}
	if(flag) cout<<"Twin snowflakes found.";
	else cout<<"No two snowflakes are alike.";
	return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值