poj 2002 Squares Hash

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 17327 Accepted: 6575

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source


问1000个点能构成多少个正方形
可以枚举两个顶点,再判断另外两个点上有没有点,已知正方形的两个顶点就能判断出另外的两个顶点。hash就行辣

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define Max 1010
#define Maxn 20010
#define MOD 20007
int xn[Maxn],ynn[Maxn];
struct pt
{
	int x,y;
	int next;
}p[Max];
int hashtable[Maxn];
int n;
int stx,sty;
int gethash(int a,int b)
{
	int temp=a*a+b*b;
	return temp%MOD;
}
void inserthash(int a,int b,int cnt)
{
	int h=gethash(a,b);
	p[cnt].next=hashtable[h];
	hashtable[h]=cnt;
}
bool searchhash()
{
	int h=gethash(stx,sty);
	int next=hashtable[h];
	while(next!=-1)
	{
		if(p[next].x==stx&&p[next].y==sty) return true;
		next=p[next].next;
	}
	return false;
}
int main()
{
	while(cin>>n)
	{
		memset(hashtable,-1,sizeof(hashtable));
		if(n==0) break;
		int tx,ty;
		for(int i=1;i<=n;i++)
		{
			cin>>tx>>ty;
			inserthash(tx,ty,i);
			p[i].x=tx;
			p[i].y=ty;
		}
		int res=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				int flag=0;
				if(p[i].x==p[j].x&&p[i].y==p[j].y) continue;
				int xx=p[i].x-p[j].x;
				int yy=p[i].y-p[j].y;
				stx=p[i].x+yy;
				sty=p[i].y-xx;
				if(searchhash()) flag=1;
				if(flag)
				{
					stx=p[j].x+yy;
					sty=p[j].y-xx;
					if(searchhash()) {res++;}
				}
				flag=0;
				stx=p[i].x-yy;
				sty=p[i].y+xx;
				if(searchhash()) flag=1;
				if(flag)
				{
					stx=p[j].x-yy;
					sty=p[j].y+xx;
					if(searchhash()) {res++;}
				}
			}
		}
		cout<<res/8<<endl;
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值