数据结构上机测试4.1:二叉树的遍历与应用1

数据结构二叉树的遍历与应用一

Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。
Input

第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。
Output

输出该二叉树的后序遍历序列。
Sample Input

ABDCEF
BDAECF
Sample Output

DBEFCA

#include "stdio.h"
#include "string.h"
#include "stdlib.h"
typedef struct  node
{
    char data;
    struct node *lc, *rc;
}bitree;
bitree * creat(int hlen , char qst[51],char hst[51])
{
    int i;
    bitree * t;
    if(hlen <= 0)
        return  NULL;
    t = (bitree *)malloc(sizeof(bitree));
    t -> data = qst[0];
    for(i = 0; i < hlen ; i++)
    {
        if(hst[i] == qst[0])
            break;
    }
    t -> lc = creat(i , qst + 1, hst);
    t -> rc = creat(hlen - i - 1, qst + i + 1,hst + i + 1);
    return t;
}
void postshow(bitree * tree)
{
    bitree * t;
    t = tree;
    if(t)
    {
        postshow(t -> lc);
        postshow(t -> rc);
        printf("%c",t -> data);
        
    }
}
int main()
{
    int hlen;
    char qst[51],hst[51];
    bitree * tree;
    scanf("%s%s",qst,hst);
    hlen = strlen(hst);
    tree = creat(hlen , qst, hst);
    postshow(tree);
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值