数据结构实验之链表四:有序链表的归并
Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100
链表的基本操作之一
#include <stdio.h>
struct node
{
int data;
struct node * next;
}*head, *p, *tail, *head1, *head2, *p1, *p2;
struct node *creat(int n)
{
head = (struct node *)malloc(sizeof(struct node));
head -> next = NULL;
tail = head;
while(n--)
{
p = (struct node *)malloc(sizeof(struct node));
scanf("%d",&p -> data);
tail -> next = p;
tail = p;
}
p -> next = NULL;
return head;
}
int main(void)
{
int m, n;
scanf("%d %d",&m, &n);
head1 = creat(m);
head2 = creat(n);
p1 = head1 -> next;
p2 = head2 -> next;
tail = head1;
free(head2);
while(p1 && p2)
{
if(p1 -> data < p2 -> data)
{
tail -> next = p1;
tail = p1;
p1 = p1 -> next;
}
else
{
tail -> next = p2;
tail = p2;
p2 = p2 -> next;
}
}
if(p1)
tail -> next = p1; //判断位置
else
tail -> next = p2;
p = head1 -> next;
while(p)
{
if(p -> next)
printf("%d ",p -> data);
else
printf("%d\n",p -> data);
p = p -> next;
}
return 0;
}