D - Group(莫队板子题)

Group

There are n men ,every man has an ID(1…n).their ID is unique. Whose ID is i and i-1 are friends, Whose ID is i and i+1 are friends. These n men stand in line. Now we select an interval of men to make some group. K men in a group can create K*K value. The value of an interval is sum of these value of groups. The people of same group’s id must be continuous. Now we chose an interval of men and want to know there should be how many groups so the value of interval is max.
Input
First line is T indicate the case number.
For each case first line is n, m(1<=n ,m<=100000) indicate there are n men and m query.
Then a line have n number indicate the ID of men from left to right.
Next m line each line has two number L,R(1<=L<=R<=n),mean we want to know the answer of [L,R].
Output
For every query output a number indicate there should be how many group so that the sum of value is max.
Sample Input
1
5 2
3 1 2 5 4
1 5
2 4
Sample Output
1
2

题意:有n个人站成一队,每个人都有一个独一无二的序号x(1<= x <= n)。现给定n个人的顺序及序号,每个区间里,序号连续的人可以在一个组,现问给定区间中,能分成最小数量的组的个数。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define N 100005
using namespace std;
int n,m,t;
int ans1[N],num[N],b[N],p[N],vis[N],belong[N],a[N];
struct data
{
    int l,r,num;
}; data a1[N];
int cmp1(data a,data b)
{
    if (belong[a.l]==belong[b.l])
        return a.r<b.r;
    return belong[a.l]<belong[b.l];
}
int main()
{
    scanf("%d",&t);
    for (int k=1;k<=t;k++)
    {
        scanf("%d%d",&n,&m);
        for (int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for (int i=1;i<=m;i++)
            scanf("%d%d",&a1[i].l,&a1[i].r),a1[i].num=i;
        int size=ceil(sqrt(n));
        for (int i=1;i<=n;i++)
            belong[i]=(i-1)/size+1;
        sort(a1+1,a1+m+1,cmp1);
        memset(vis,0,sizeof(vis));
        memset(ans1,0,sizeof(ans1));
        int l=1;  int r=0; int ans=0;
        for (int i=1;i<=m;i++)
        {
            while (r<a1[i].r)
            {
                r++;
                vis[a[r]]=1;
                if (vis[a[r]-1]&&vis[a[r]+1])
                    ans--;
                if (!vis[a[r]-1]&&!vis[a[r]+1])
                    ans++;
            }
            while (r>a1[i].r)
            {
                vis[a[r]]=0;
                if (vis[a[r]-1]&&vis[a[r]+1])
                    ans++;
                if (!vis[a[r]-1]&&!vis[a[r]+1])
                    ans--;
                r--;
            }
            while (l>a1[i].l)
            {
                l--;
                if (vis[a[l]-1]&&vis[a[l]+1])
                    ans--;
                if (!vis[a[l]-1]&&!vis[a[l]+1])
                    ans++;
                vis[a[l]]=1;
            }
            while (l<a1[i].l)
            {
                vis[a[l]]=0;
                if (vis[a[l]-1]&&vis[a[l]+1])
                    ans++;
                if (!vis[a[l]-1]&&!vis[a[l]+1])
                    ans--;
                l++;
            }
            ans1[a1[i].num]=ans;
        }
        for (int i=1;i<=m;i++)
            printf("%d\n",ans1[i]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值